/[svn]/gigedit/trunk/debian/rules
ViewVC logotype

Annotation of /gigedit/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2795 - (hide annotations) (download)
Fri Jul 17 12:06:00 2015 UTC (8 years, 9 months ago) by schoenebeck
File size: 2674 byte(s)
* Preparations for new release (Gigedit 1.0.0).

1 schoenebeck 1152 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9 schoenebeck 2795 APPNAME := gigedit
10    
11 schoenebeck 1152 # Uncomment this to turn on verbose mode.
12     export DH_VERBOSE=1
13    
14     # These are used for cross-compiling and for saving the configure script
15     # from having to guess our platform (since we know it already)
16     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
17     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
18    
19     CFLAGS = -Wall -g
20    
21     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22 schoenebeck 1214 CFLAGS += -O0 -g
23 schoenebeck 1152 else
24 schoenebeck 1214 CFLAGS += -O2 -g
25 schoenebeck 1152 endif
26    
27     config.status:
28     dh_testdir
29     # Add here commands to configure the package.
30 schoenebeck 2795 if [ -e Makefile.svn ] ; then \
31     $(MAKE) -f Makefile.svn; \
32 schoenebeck 1452 fi
33 schoenebeck 1152 chmod a+x configure
34     CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
35    
36    
37     build: build-stamp
38    
39     build-stamp: config.status
40     dh_testdir
41    
42     # Add here commands to compile the package.
43     $(MAKE)
44    
45     touch build-stamp
46    
47     clean:
48     dh_testdir
49     dh_testroot
50     rm -f build-stamp
51    
52     # Add here commands to clean up after the build process.
53 schoenebeck 2795 if [ -e Makefile.svn ] ; then \
54     $(MAKE) -f Makefile.svn; \
55 schoenebeck 1452 fi
56 schoenebeck 1152 chmod a+x configure
57     -$(MAKE) distclean
58     ifneq "$(wildcard /usr/share/misc/config.sub)" ""
59     cp -f /usr/share/misc/config.sub config.sub
60     endif
61     ifneq "$(wildcard /usr/share/misc/config.guess)" ""
62     cp -f /usr/share/misc/config.guess config.guess
63     endif
64    
65    
66     dh_clean
67    
68     install: build
69     dh_testdir
70     dh_testroot
71     dh_clean -k
72     dh_installdirs
73    
74 schoenebeck 2795 # Add here commands to install the package temporarily below debian/.
75     $(MAKE) DESTDIR=$(CURDIR)/debian/$(APPNAME) install
76 schoenebeck 1152
77    
78     # Build architecture-independent files here.
79     binary-indep: build install
80     # We have nothing to do by default.
81    
82     # Build architecture-dependent files here.
83     binary-arch: build install
84     dh_testdir
85     dh_testroot
86     dh_installchangelogs ChangeLog
87     dh_installdocs
88     dh_installexamples
89     dh_install
90     # dh_installmenu
91     # dh_installdebconf
92     # dh_installlogrotate
93     # dh_installemacsen
94     # dh_installpam
95     # dh_installmime
96     # dh_installinit
97     # dh_installcron
98     # dh_installinfo
99     # dh_installman debian/gigedit.1
100     dh_link
101 schoenebeck 1214 # dh_strip
102 schoenebeck 1152 dh_compress
103     dh_fixperms
104     # dh_perl
105     # dh_python
106     # dh_makeshlibs
107     dh_installdeb
108     dh_shlibdeps
109     dh_gencontrol
110     dh_md5sums
111     dh_builddeb
112    
113     binary: binary-indep binary-arch
114     .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC