/[svn]/libgig/trunk/debian/control
ViewVC logotype

Contents of /libgig/trunk/debian/control

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2543 - (show annotations) (download)
Sat May 10 02:06:58 2014 UTC (9 years, 11 months ago) by schoenebeck
File size: 2935 byte(s)
* Initial support for sample based instruments in KORG's file format (.KMP
  and .KSF files) -> Korg.h, Korg.cpp.
* Added new command line tool "korgdump" (and a man page for it).
* Added new command line tool "korg2gig" (and a man page for it), for
  converting KORG sounds to Giga format.
* riftree tool: Added more command line options for being able to also dump
  other kind of file formats similar but not equal to the RIFF format.
* gig.h/.cpp: Added new method File::GetGroup(String name) for retrieving
  group by name.
* RIFF.h/.cpp: Added support for loading RIFF-like files with a bit
  different layout than "real" RIFF files (used for KORG format support).
* RIFF.h/.cpp: Added new method Chunk::GetFile().
* RIFF.h/.cpp: Added new method Chunk::GetLayout().
* Bumped version (3.3.0.svn9).

1 Source: libgig
2 Section: devel
3 Priority: optional
4 Maintainer: Matt Flax <flatmax@pgb.unsw.edu.au>
5 Build-Depends: debhelper (>= 4.0.0), pkg-config, libsndfile1-dev, doxygen, uuid-dev
6 Standards-Version: 3.7.2
7
8 Package: libgig-dev
9 Section: libdevel
10 Architecture: any
11 Depends: libgig6 (= ${Source-Version})
12 Description: library for accessing Gigasampler, DLS, SoundFont and KORG files
13 libgig is a C++ library for reading, modifying and creating Gigasampler /
14 GigaStudio (.gig) files, DLS (Downloadable Sounds) Level 1/2 files, SoundFont
15 version 2 (.sf2) and KORG sound files (.KMP and .KSF). These files are
16 typically used in modern day audio waveform samplers and synthesizer keyboards.
17 .
18 Since the Gigasampler / GigaStudio and DLS formats are based ontop of the
19 binary RIFF container format, this library also provides convenient access to
20 RIFF files in general.
21 .
22 For more information visit
23 http://www.linuxsampler.org/libgig/
24 .
25 This package contains the header files needed for development with libgig.
26 You will need this only if you intend to compile programs that use this
27 library.
28
29 Package: libgig6
30 Section: libs
31 Architecture: any
32 Depends: ${shlibs:Depends}, ${misc:Depends}
33 Conflicts: libgig3c2, libgig
34 Replaces: libgig3c2, libgig
35 Description: library for accessing Gigasampler, DLS, SoundFont and KORG files
36 libgig is a C++ library for reading, modifying and creating Gigasampler /
37 GigaStudio (.gig) files, DLS (Downloadable Sounds) Level 1/2 files, SoundFont
38 version 2 (.sf2) files and KORG sound files (.KMP and .KSF). These files are
39 typically used in modern day audio waveform samplers and synthesizer keyboards.
40 .
41 Since the Gigasampler / GigaStudio and DLS formats are based ontop of the
42 binary RIFF container format, this library also provides convenient access to
43 RIFF files in general.
44 .
45 For more information visit
46 http://www.linuxsampler.org/libgig/
47
48 Package: gigtools
49 Section: utils
50 Architecture: any
51 Depends: ${shlibs:Depends}, ${misc:Depends}
52 Description: command line tools for Gigasampler, SF2, DLS and KORG files
53 Raw file handling for audio sampler files based on either DLS Level 1/2,
54 Gigasampler / GigaStudio, SoundFont version 2 and KORG sound format (.KSF and
55 .KMP). These files are typically used in modern day audio waveform samplers
56 and synthesizer keyboards.
57 .
58 This package contains the following command line tools:
59 .
60 gigdump:
61 Prints out the content of a .gig file.
62 gigextract:
63 Extracts audio samples from a .gig file.
64 gigmerge:
65 Combines multiple .gig files to one .gig file.
66 gig2mono:
67 Converts .gig files from stereo to mono.
68 dlsdump:
69 Prints out the content of a DLS file.
70 rifftree:
71 Prints out the RIFF tree of an arbitrary RIFF container file.
72 sf2dump:
73 Prints out the content of a .sf2 file.
74 korgdump:
75 Prints out the content of KORG sound files (.KSF, .KMP).
76 korg2gig:
77 Converts KORG (.KSF, .KMP) sound files to GigaStudio (.gig) files.

  ViewVC Help
Powered by ViewVC