/[svn]/libgig/trunk/debian/rules
ViewVC logotype

Contents of /libgig/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2865 - (show annotations) (download)
Wed Apr 6 17:49:03 2016 UTC (8 years ago) by schoenebeck
File size: 3164 byte(s)
* Debian packaging: Fixed unnecessary lib dependencies of projects linked
  against libgig by wiping the 'dependency_libs' fields from all .la
  files. Note that this might require manual adjustments to projects
  linking statically against libgig
  (see https://wiki.debian.org/ReleaseGoals/LAFileRemoval for details).
* Debian packaging: Assigned linuxsampler-devel@lists.sourceforge.net as
  maintainer of this package.

1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 # This is the debhelper compatibility version to use.
10 export DH_COMPAT=7
11
12 # These are used for cross-compiling and for saving the configure script
13 # from having to guess our platform (since we know it already)
14 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
15 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16
17
18 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
19 CFLAGS += -g
20 endif
21 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22 INSTALL_PROGRAM += -s
23 endif
24
25 config.status: configure
26 dh_testdir
27 # Add here commands to configure the package.
28 chmod a+x configure
29 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
30
31
32 build: build-stamp
33 build-stamp: config.status
34 dh_testdir
35
36 # Add here commands to compile the package.
37 $(MAKE)
38
39 # the build should fail if the tests are not successful
40 #$(MAKE) check
41
42 # Wiping 'dependency_libs' fields from all .la files
43 # (see https://wiki.debian.org/ReleaseGoals/LAFileRemoval for details).
44 # This is a workaround to avoid unnecessary lib dependencies of
45 # apps/libs that link against libgig. Note that this might require
46 # manual adjustments to projects linking statically against libgig.
47 sed -i "/dependency_libs/ s/'.*'/''/" `find . -name '*.la'` `find . -name '*.lai'`
48 # rebuild of gigtools is required to get rid of their unnecessary lib dependencies as well
49 ( cd src/tools && $(MAKE) clean )
50 # explicitly remove "-luuid" occurrences from src/tools/Makefile
51 sed -i "s/-luuid//" src/tools/Makefile
52 # now rebuild gigtools
53 $(MAKE)
54
55 # generate Doxygen API documentation
56 $(MAKE) docs
57
58 touch build-stamp
59
60 clean:
61 dh_testdir
62 dh_testroot
63 rm -f build-stamp
64
65 $(MAKE) -f Makefile.svn || true
66 chmod a+x configure
67 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
68
69
70 # Add here commands to clean up after the build process.
71 -$(MAKE) distclean
72
73 dh_clean -a
74
75 install: build
76 dh_testdir
77 dh_testroot
78 dh_clean -k -a
79 dh_installdirs
80
81 # Add here commands to install the package into debian/tmp
82 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
83
84 # Build architecture-independent files here.
85 binary-indep: build install
86 # We have nothing to do by default.
87
88 # Build architecture-dependent files here.
89 binary-arch: build install
90 dh_testdir
91 dh_testroot
92 dh_install -a --list-missing
93 dh_installchangelogs -a ChangeLog
94 dh_installdocs -a
95 # dh_installexamples
96 # dh_installmenu
97 # dh_installdebconf
98 # dh_installlogrotate
99 # dh_installemacsen
100 # dh_installpam
101 # dh_installmime
102 # dh_installinit
103 # dh_installcron
104 # dh_installinfo
105 dh_installman
106 dh_link
107 # dh_strip -a
108 dh_compress -a
109 dh_fixperms -a
110 # dh_perl
111 # dh_python
112 dh_makeshlibs
113 dh_installdeb
114 dh_shlibdeps
115 dh_gencontrol
116 dh_md5sums
117 dh_builddeb
118
119 binary: binary-indep binary-arch
120 .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC