/[svn]/linuxsampler/trunk/debian/rules
ViewVC logotype

Annotation of /linuxsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1220 - (hide annotations) (download)
Tue Jun 5 15:55:05 2007 UTC (16 years, 11 months ago) by schoenebeck
File size: 2648 byte(s)
* minor Debian packaging fix: abort package build process when
  Makefile.cvs failed (only relevant to CVS versions of LS)

1 schoenebeck 375 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     #export DH_VERBOSE=1
11    
12     CFLAGS = -Wall -g
13    
14     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15     CFLAGS += -O0
16     else
17     CFLAGS += -O2
18     endif
19    
20     configure: configure-stamp
21     configure-stamp:
22     dh_testdir
23     # Add here commands to configure the package.
24 schoenebeck 1220 if [ -e Makefile.cvs ] ; then \
25     $(MAKE) -f Makefile.cvs; \
26     fi
27 flax 591 chmod a+x configure
28 schoenebeck 375 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
29     touch configure-stamp
30    
31    
32     build: build-stamp
33    
34     build-stamp: configure-stamp
35     dh_testdir
36    
37     # Add here commands to compile the package.
38     $(MAKE)
39 flax 591 # docbook-to-man debian/linuxsampler.sgml > linuxsampler.1
40 schoenebeck 375
41 flax 591 # $(MAKE)
42    
43 schoenebeck 698 # generate Doxygen API documentation
44     $(MAKE) docs
45    
46 schoenebeck 375 touch build-stamp
47    
48     clean:
49     dh_testdir
50     dh_testroot
51     rm -f build-stamp configure-stamp
52    
53 schoenebeck 1220 if [ -e Makefile.cvs ] ; then \
54     $(MAKE) -f Makefile.cvs; \
55     fi;
56 schoenebeck 375 # Add here commands to clean up after the build process.
57 flax 599 chmod a+x configure
58     ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
59    
60 schoenebeck 375 -$(MAKE) distclean
61    
62     dh_clean
63    
64     install: build
65     dh_testdir
66     dh_testroot
67     dh_clean -k
68     dh_installdirs
69    
70 schoenebeck 698 # Add here commands to install the package into debian/tmp.
71     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
72 schoenebeck 375
73    
74     # Build architecture-independent files here.
75     binary-indep: build install
76     # We have nothing to do by default.
77    
78     # Build architecture-dependent files here.
79     binary-arch: build install
80     dh_testdir
81     dh_testroot
82 schoenebeck 698 dh_install -a --list-missing
83     dh_installchangelogs -a ChangeLog
84     dh_installdocs -a
85 schoenebeck 375 dh_installexamples
86     # dh_install
87     # dh_installmenu
88     # dh_installdebconf
89     # dh_installlogrotate
90     # dh_installemacsen
91     # dh_installpam
92     # dh_installmime
93     # dh_installinit
94     # dh_installcron
95     # dh_installinfo
96 schoenebeck 698 dh_installman man/linuxsampler.1
97 schoenebeck 375 dh_link
98 schoenebeck 1210 # dh_strip
99 schoenebeck 375 dh_compress
100     dh_fixperms
101     # dh_perl
102     # dh_python
103 schoenebeck 698 dh_makeshlibs -pliblinuxsampler
104     dh_installdeb -a
105 flax 591 dh_shlibdeps # -L linuxsampler -l debian/linuxsampler/usr/lib/linuxsampler
106 schoenebeck 698 dh_shlibdeps -pliblinuxsampler
107     dh_gencontrol -a
108     dh_md5sums -a
109     dh_builddeb -a
110 schoenebeck 375
111     binary: binary-indep binary-arch
112     .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC