/[svn]/linuxsampler/trunk/debian/rules
ViewVC logotype

Annotation of /linuxsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 375 - (hide annotations) (download)
Sat Feb 12 14:00:51 2005 UTC (19 years, 2 months ago) by schoenebeck
File size: 2137 byte(s)
* added Debian packaging files

1 schoenebeck 375 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     #export DH_VERBOSE=1
11    
12     CFLAGS = -Wall -g
13    
14     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15     CFLAGS += -O0
16     else
17     CFLAGS += -O2
18     endif
19    
20     configure: configure-stamp
21     configure-stamp:
22     dh_testdir
23     # Add here commands to configure the package.
24     $(MAKE) -f Makefile.cvs
25     ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
26     touch configure-stamp
27    
28    
29     build: build-stamp
30    
31     build-stamp: configure-stamp
32     dh_testdir
33    
34     # Add here commands to compile the package.
35     $(MAKE)
36     #docbook-to-man debian/linuxsampler.sgml > linuxsampler.1
37    
38     touch build-stamp
39    
40     clean:
41     dh_testdir
42     dh_testroot
43     rm -f build-stamp configure-stamp
44    
45     # Add here commands to clean up after the build process.
46     -$(MAKE) distclean
47     -$(MAKE) -f Makefile.cvs clean
48    
49     dh_clean
50    
51     install: build
52     dh_testdir
53     dh_testroot
54     dh_clean -k
55     dh_installdirs
56    
57     # Add here commands to install the package into debian/linuxsampler.
58     $(MAKE) install DESTDIR=$(CURDIR)/debian/linuxsampler
59    
60    
61     # Build architecture-independent files here.
62     binary-indep: build install
63     # We have nothing to do by default.
64    
65     # Build architecture-dependent files here.
66     binary-arch: build install
67     dh_testdir
68     dh_testroot
69     dh_installchangelogs
70     dh_installdocs
71     dh_installexamples
72     # dh_install
73     # dh_installmenu
74     # dh_installdebconf
75     # dh_installlogrotate
76     # dh_installemacsen
77     # dh_installpam
78     # dh_installmime
79     # dh_installinit
80     # dh_installcron
81     # dh_installinfo
82     dh_installman
83     dh_link
84     dh_strip
85     dh_compress
86     dh_fixperms
87     # dh_perl
88     # dh_python
89     # dh_makeshlibs
90     dh_installdeb
91     dh_shlibdeps
92     dh_gencontrol
93     dh_md5sums
94     dh_builddeb
95    
96     binary: binary-indep binary-arch
97     .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC