/[svn]/linuxsampler/trunk/debian/rules
ViewVC logotype

Annotation of /linuxsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 591 - (hide annotations) (download)
Tue May 31 19:33:18 2005 UTC (18 years, 10 months ago) by flax
File size: 2255 byte(s)
* altered and fixed debian packaging

1 schoenebeck 375 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     #export DH_VERBOSE=1
11    
12     CFLAGS = -Wall -g
13    
14     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15     CFLAGS += -O0
16     else
17     CFLAGS += -O2
18     endif
19    
20     configure: configure-stamp
21     configure-stamp:
22     dh_testdir
23     # Add here commands to configure the package.
24     $(MAKE) -f Makefile.cvs
25 flax 591 chmod a+x configure
26 schoenebeck 375 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
27     touch configure-stamp
28    
29    
30     build: build-stamp
31    
32     build-stamp: configure-stamp
33     dh_testdir
34    
35     # Add here commands to compile the package.
36     $(MAKE)
37 flax 591 # docbook-to-man debian/linuxsampler.sgml > linuxsampler.1
38 schoenebeck 375
39 flax 591 # $(MAKE)
40    
41 schoenebeck 375 touch build-stamp
42    
43     clean:
44     dh_testdir
45     dh_testroot
46     rm -f build-stamp configure-stamp
47    
48     # Add here commands to clean up after the build process.
49     -$(MAKE) distclean
50     -$(MAKE) -f Makefile.cvs clean
51    
52     dh_clean
53    
54     install: build
55     dh_testdir
56     dh_testroot
57     dh_clean -k
58     dh_installdirs
59    
60     # Add here commands to install the package into debian/linuxsampler.
61     $(MAKE) install DESTDIR=$(CURDIR)/debian/linuxsampler
62    
63    
64     # Build architecture-independent files here.
65     binary-indep: build install
66     # We have nothing to do by default.
67    
68     # Build architecture-dependent files here.
69     binary-arch: build install
70     dh_testdir
71     dh_testroot
72     dh_installchangelogs
73     dh_installdocs
74     dh_installexamples
75     # dh_install
76     # dh_installmenu
77     # dh_installdebconf
78     # dh_installlogrotate
79     # dh_installemacsen
80     # dh_installpam
81     # dh_installmime
82     # dh_installinit
83     # dh_installcron
84     # dh_installinfo
85 flax 591 dh_installman debian/linuxsampler.1
86 schoenebeck 375 dh_link
87     dh_strip
88     dh_compress
89     dh_fixperms
90     # dh_perl
91     # dh_python
92     # dh_makeshlibs
93     dh_installdeb
94 flax 591 dh_shlibdeps # -L linuxsampler -l debian/linuxsampler/usr/lib/linuxsampler
95 schoenebeck 375 dh_gencontrol
96     dh_md5sums
97     dh_builddeb
98    
99     binary: binary-indep binary-arch
100     .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC