/[svn]/linuxsampler/trunk/debian/rules
ViewVC logotype

Annotation of /linuxsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 698 - (hide annotations) (download)
Tue Jul 19 15:51:19 2005 UTC (18 years, 9 months ago) by schoenebeck
File size: 2559 byte(s)
Debian packaging changes:
- Updated packaging files for the library nature of LinuxSampler.
- Automatically generate Doxygen API documentation.

1 schoenebeck 375 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     #export DH_VERBOSE=1
11    
12     CFLAGS = -Wall -g
13    
14     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15     CFLAGS += -O0
16     else
17     CFLAGS += -O2
18     endif
19    
20     configure: configure-stamp
21     configure-stamp:
22     dh_testdir
23     # Add here commands to configure the package.
24     $(MAKE) -f Makefile.cvs
25 flax 591 chmod a+x configure
26 schoenebeck 375 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
27     touch configure-stamp
28    
29    
30     build: build-stamp
31    
32     build-stamp: configure-stamp
33     dh_testdir
34    
35     # Add here commands to compile the package.
36     $(MAKE)
37 flax 591 # docbook-to-man debian/linuxsampler.sgml > linuxsampler.1
38 schoenebeck 375
39 flax 591 # $(MAKE)
40    
41 schoenebeck 698 # generate Doxygen API documentation
42     $(MAKE) docs
43    
44 schoenebeck 375 touch build-stamp
45    
46     clean:
47     dh_testdir
48     dh_testroot
49     rm -f build-stamp configure-stamp
50    
51 flax 599 -$(MAKE) -f Makefile.cvs
52 schoenebeck 375 # Add here commands to clean up after the build process.
53 flax 599 chmod a+x configure
54     ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
55    
56 schoenebeck 375 -$(MAKE) distclean
57    
58     dh_clean
59    
60     install: build
61     dh_testdir
62     dh_testroot
63     dh_clean -k
64     dh_installdirs
65    
66 schoenebeck 698 # Add here commands to install the package into debian/tmp.
67     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
68 schoenebeck 375
69    
70     # Build architecture-independent files here.
71     binary-indep: build install
72     # We have nothing to do by default.
73    
74     # Build architecture-dependent files here.
75     binary-arch: build install
76     dh_testdir
77     dh_testroot
78 schoenebeck 698 dh_install -a --list-missing
79     dh_installchangelogs -a ChangeLog
80     dh_installdocs -a
81 schoenebeck 375 dh_installexamples
82     # dh_install
83     # dh_installmenu
84     # dh_installdebconf
85     # dh_installlogrotate
86     # dh_installemacsen
87     # dh_installpam
88     # dh_installmime
89     # dh_installinit
90     # dh_installcron
91     # dh_installinfo
92 schoenebeck 698 dh_installman man/linuxsampler.1
93 schoenebeck 375 dh_link
94     dh_strip
95     dh_compress
96     dh_fixperms
97     # dh_perl
98     # dh_python
99 schoenebeck 698 dh_makeshlibs -pliblinuxsampler
100     dh_installdeb -a
101 flax 591 dh_shlibdeps # -L linuxsampler -l debian/linuxsampler/usr/lib/linuxsampler
102 schoenebeck 698 dh_shlibdeps -pliblinuxsampler
103     dh_gencontrol -a
104     dh_md5sums -a
105     dh_builddeb -a
106 schoenebeck 375
107     binary: binary-indep binary-arch
108     .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC