/[svn]/qsampler/trunk/debian/rules
ViewVC logotype

Annotation of /qsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 413 - (hide annotations) (download)
Mon Feb 28 22:19:07 2005 UTC (19 years, 1 month ago) by schoenebeck
File size: 2585 byte(s)
* added Debian packaging structure

1 schoenebeck 413 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     export DH_VERBOSE=1
11    
12     export QTDIR=/usr/share/qt3
13    
14     # These are used for cross-compiling and for saving the configure script
15     # from having to guess our platform (since we know it already)
16     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
17     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
18    
19     CFLAGS = -Wall -g
20    
21     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22     CFLAGS += -O0
23     else
24     CFLAGS += -O2
25     endif
26    
27     config.status:
28     dh_testdir
29     # Add here commands to configure the package.
30     $(MAKE) -f Makefile.cvs
31     CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
32    
33    
34     build: build-stamp
35    
36     build-stamp: config.status
37     dh_testdir
38    
39     # Add here commands to compile the package.
40     $(MAKE)
41     #docbook-to-man debian/qsampler.sgml > qsampler.1
42    
43     touch build-stamp
44    
45     clean:
46     dh_testdir
47     dh_testroot
48     rm -f build-stamp
49    
50     # Add here commands to clean up after the build process.
51     -$(MAKE) distclean
52     -$(MAKE) -f Makefile.cvs clean
53     ifneq "$(wildcard /usr/share/misc/config.sub)" ""
54     cp -f /usr/share/misc/config.sub config.sub
55     endif
56     ifneq "$(wildcard /usr/share/misc/config.guess)" ""
57     cp -f /usr/share/misc/config.guess config.guess
58     endif
59    
60    
61     dh_clean
62    
63     install: build
64     dh_testdir
65     dh_testroot
66     dh_clean -k
67     dh_installdirs
68    
69     # Add here commands to install the package into debian/qsampler.
70     $(MAKE) install DESTDIR=$(CURDIR)/debian/qsampler
71    
72    
73     # Build architecture-independent files here.
74     binary-indep: build install
75     # We have nothing to do by default.
76    
77     # Build architecture-dependent files here.
78     binary-arch: build install
79     dh_testdir
80     dh_testroot
81     dh_installchangelogs ChangeLog
82     dh_installdocs
83     dh_installexamples
84     dh_install
85     # dh_installmenu
86     # dh_installdebconf
87     # dh_installlogrotate
88     # dh_installemacsen
89     # dh_installpam
90     # dh_installmime
91     # dh_installinit
92     # dh_installcron
93     # dh_installinfo
94     dh_installman
95     dh_link
96     dh_strip
97     dh_compress
98     dh_fixperms
99     # dh_perl
100     # dh_python
101     # dh_makeshlibs
102     dh_installdeb
103     dh_shlibdeps
104     dh_gencontrol
105     dh_md5sums
106     dh_builddeb
107    
108     binary: binary-indep binary-arch
109     .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC