/[svn]/qsampler/trunk/debian/rules
ViewVC logotype

Annotation of /qsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 606 - (hide annotations) (download)
Fri Jun 3 12:12:02 2005 UTC (18 years, 10 months ago) by flax
File size: 2639 byte(s)
* fixed debian packaging

1 schoenebeck 413 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     export DH_VERBOSE=1
11    
12     export QTDIR=/usr/share/qt3
13    
14     # These are used for cross-compiling and for saving the configure script
15     # from having to guess our platform (since we know it already)
16     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
17     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
18    
19     CFLAGS = -Wall -g
20    
21     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22     CFLAGS += -O0
23     else
24     CFLAGS += -O2
25     endif
26    
27     config.status:
28     dh_testdir
29     # Add here commands to configure the package.
30     $(MAKE) -f Makefile.cvs
31 flax 606 chmod a+x configure
32 schoenebeck 413 CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
33    
34    
35     build: build-stamp
36    
37     build-stamp: config.status
38     dh_testdir
39    
40     # Add here commands to compile the package.
41     $(MAKE)
42     #docbook-to-man debian/qsampler.sgml > qsampler.1
43    
44     touch build-stamp
45    
46     clean:
47     dh_testdir
48     dh_testroot
49     rm -f build-stamp
50    
51     # Add here commands to clean up after the build process.
52 flax 606 -$(MAKE) -f Makefile.cvs
53     chmod a+x configure
54 schoenebeck 413 -$(MAKE) distclean
55     ifneq "$(wildcard /usr/share/misc/config.sub)" ""
56     cp -f /usr/share/misc/config.sub config.sub
57     endif
58     ifneq "$(wildcard /usr/share/misc/config.guess)" ""
59     cp -f /usr/share/misc/config.guess config.guess
60     endif
61    
62    
63     dh_clean
64    
65     install: build
66     dh_testdir
67     dh_testroot
68     dh_clean -k
69     dh_installdirs
70    
71     # Add here commands to install the package into debian/qsampler.
72     $(MAKE) install DESTDIR=$(CURDIR)/debian/qsampler
73    
74    
75     # Build architecture-independent files here.
76     binary-indep: build install
77     # We have nothing to do by default.
78    
79     # Build architecture-dependent files here.
80     binary-arch: build install
81     dh_testdir
82     dh_testroot
83     dh_installchangelogs ChangeLog
84     dh_installdocs
85     dh_installexamples
86     dh_install
87     # dh_installmenu
88     # dh_installdebconf
89     # dh_installlogrotate
90     # dh_installemacsen
91     # dh_installpam
92     # dh_installmime
93     # dh_installinit
94     # dh_installcron
95     # dh_installinfo
96 flax 606 dh_installman debian/qsampler.1
97 schoenebeck 413 dh_link
98     dh_strip
99     dh_compress
100     dh_fixperms
101     # dh_perl
102     # dh_python
103     # dh_makeshlibs
104     dh_installdeb
105     dh_shlibdeps
106     dh_gencontrol
107     dh_md5sums
108     dh_builddeb
109    
110     binary: binary-indep binary-arch
111     .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC