/[svn]/qsampler/trunk/debian/rules
ViewVC logotype

Contents of /qsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2832 - (show annotations) (download)
Fri Jul 24 14:54:58 2015 UTC (8 years, 8 months ago) by capela
File size: 1861 byte(s)
- Debian rules bump.
1 #!/usr/bin/make -f
2 APPNAME := qsampler
3
4 # Uncomment this to turn on verbose mode.
5 #export DH_VERBOSE=1
6
7 # This is the debhelper compatibility version to use.
8 #export DH_COMPAT=4
9
10 # Set Qt5 environment for qtchooser.
11 export QT_SELECT=5
12
13 CFLAGS = -g
14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15 CFLAGS += -O0
16 else
17 CFLAGS += -O2
18 endif
19
20 configure: configure-stamp
21 configure-stamp:
22 dh_testdir
23
24 # Add here commands to configure the package.
25 -$(MAKE) -f Makefile.git
26
27 ./configure --prefix=/usr
28 # --- end custom part for configure
29
30 touch configure-stamp
31
32 build: build-stamp
33 build-stamp: configure-stamp
34 dh_testdir
35
36 # Add here commands to compile the package.
37 $(MAKE)
38 # --- end custom part for compiling
39
40 touch build-stamp
41
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp configure-stamp
46
47 # Add here commands to clean up after the build process.
48 -$(MAKE) -f Makefile.git clean
49 # --- end custom part for cleaning up
50
51 dh_clean
52
53 install: build
54 dh_testdir
55 dh_testroot
56 dh_clean -k
57 dh_installdirs
58
59 # Add here commands to install the package
60 $(MAKE) install DESTDIR=/usr/src/packages/BUILD/debian/$(APPNAME)
61 # --- end custom part for installing
62
63 # Build architecture-independent files here.
64 binary-indep: build install
65 # We have nothing to do by default.
66
67 # Build architecture-dependent files here.
68 binary-arch: build install
69 dh_testdir
70 dh_testroot
71 # dh_installdebconf
72 dh_installdocs
73 dh_installexamples
74 dh_installmenu
75 # dh_installlogrotate
76 # dh_installemacsen
77 # dh_installpam
78 # dh_installmime
79 # dh_installinit
80 dh_installcron
81 dh_installman
82 dh_installinfo
83 # dh_undocumented
84 dh_installchangelogs
85 dh_link
86 dh_strip
87 dh_compress
88 dh_fixperms
89 # dh_makeshlibs
90 dh_installdeb
91 # dh_perl
92 dh_shlibdeps
93 dh_gencontrol
94 dh_md5sums
95 dh_builddeb
96
97 binary: binary-indep binary-arch
98 .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC