/[svn]/libgig/trunk/debian/libgig6.postinst
ViewVC logotype

Annotation of /libgig/trunk/debian/libgig6.postinst

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2589 - (hide annotations) (download)
Sun Jun 1 18:32:03 2014 UTC (9 years, 9 months ago) by schoenebeck
Original Path: libgig/trunk/debian/postinst
File size: 974 byte(s)
* Debian: Fixed packaging regarding libgig's new libdir.

1 schoenebeck 2589 #!/bin/sh
2     # postinst script for libgig
3     #
4     # see: dh_installdeb(1)
5    
6     set -e
7    
8     # summary of how this script can be called:
9     # * <postinst> `configure' <most-recently-configured-version>
10     # * <old-postinst> `abort-upgrade' <new version>
11     # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12     # <new-version>
13     # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
14     # <failed-install-package> <version> `removing'
15     # <conflicting-package> <version>
16     # for details, see http://www.debian.org/doc/debian-policy/ or
17     # the debian-policy package
18     #
19    
20     case "$1" in
21     configure)
22     echo '/usr/lib/libgig' >> /etc/ld.so.conf
23     ldconfig
24     ;;
25    
26     abort-upgrade|abort-remove|abort-deconfigure)
27    
28     ;;
29    
30     *)
31     echo "postinst called with unknown argument \`$1'" >&2
32     exit 1
33     ;;
34     esac
35    
36     # dh_installdeb will replace this with shell code automatically
37     # generated by other debhelper scripts.
38    
39     #DEBHELPER#
40    
41     exit 0

  ViewVC Help
Powered by ViewVC