/[svn]/libgig/trunk/debian/rules
ViewVC logotype

Annotation of /libgig/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1953 - (hide annotations) (download)
Thu Jul 30 08:16:02 2009 UTC (14 years, 8 months ago) by schoenebeck
File size: 2484 byte(s)
* preparations for release 3.3.0

1 schoenebeck 186 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # GNU copyright 1997 to 1999 by Joey Hess.
5    
6     # Uncomment this to turn on verbose mode.
7     #export DH_VERBOSE=1
8    
9     # This is the debhelper compatibility version to use.
10     export DH_COMPAT=4
11    
12     # These are used for cross-compiling and for saving the configure script
13     # from having to guess our platform (since we know it already)
14     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
15     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16    
17    
18     ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
19     CFLAGS += -g
20     endif
21     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22     INSTALL_PROGRAM += -s
23     endif
24    
25     config.status: configure
26     dh_testdir
27     # Add here commands to configure the package.
28 schoenebeck 521 chmod a+x configure
29 schoenebeck 186 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
30    
31    
32     build: build-stamp
33     build-stamp: config.status
34     dh_testdir
35    
36     # Add here commands to compile the package.
37     $(MAKE)
38    
39     # the build should fail if the tests are not successful
40     #$(MAKE) check
41    
42 schoenebeck 313 # generate Doxygen API documentation
43     $(MAKE) docs
44    
45 schoenebeck 186 touch build-stamp
46    
47     clean:
48     dh_testdir
49     dh_testroot
50     rm -f build-stamp
51    
52 schoenebeck 953 $(MAKE) -f Makefile.cvs || true
53 schoenebeck 521 chmod a+x configure
54 flax 440 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
55    
56    
57 schoenebeck 186 # Add here commands to clean up after the build process.
58     -$(MAKE) distclean
59    
60     dh_clean -a
61    
62     install: build
63     dh_testdir
64     dh_testroot
65     dh_clean -k -a
66     dh_installdirs
67    
68     # Add here commands to install the package into debian/tmp
69     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
70    
71     # Build architecture-independent files here.
72     binary-indep: build install
73     # We have nothing to do by default.
74    
75     # Build architecture-dependent files here.
76     binary-arch: build install
77     dh_testdir
78     dh_testroot
79     dh_install -a --list-missing
80     dh_installchangelogs -a ChangeLog
81     dh_installdocs -a
82     # dh_installexamples
83     # dh_installmenu
84     # dh_installdebconf
85     # dh_installlogrotate
86     # dh_installemacsen
87     # dh_installpam
88     # dh_installmime
89     # dh_installinit
90     # dh_installcron
91     # dh_installinfo
92     dh_installman
93 schoenebeck 1953 dh_link
94     # dh_strip -a
95 schoenebeck 186 dh_compress -a
96     dh_fixperms -a
97     # dh_perl
98     # dh_python
99 schoenebeck 1953 dh_makeshlibs
100     dh_installdeb
101     dh_shlibdeps
102     dh_gencontrol
103     dh_md5sums
104     dh_builddeb
105 schoenebeck 186
106     binary: binary-indep binary-arch
107     .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC