/[svn]/libgig/trunk/debian/rules
ViewVC logotype

Annotation of /libgig/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 440 - (hide annotations) (download)
Thu Mar 10 05:53:20 2005 UTC (19 years, 1 month ago) by flax
File size: 2510 byte(s)
* fixed debian packaging

1 schoenebeck 186 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # GNU copyright 1997 to 1999 by Joey Hess.
5    
6     # Uncomment this to turn on verbose mode.
7     #export DH_VERBOSE=1
8    
9     # This is the debhelper compatibility version to use.
10     export DH_COMPAT=4
11    
12     # These are used for cross-compiling and for saving the configure script
13     # from having to guess our platform (since we know it already)
14     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
15     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16    
17    
18     ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
19     CFLAGS += -g
20     endif
21     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22     INSTALL_PROGRAM += -s
23     endif
24    
25     config.status: configure
26     dh_testdir
27     # Add here commands to configure the package.
28     ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
29    
30    
31     build: build-stamp
32     build-stamp: config.status
33     dh_testdir
34    
35     # Add here commands to compile the package.
36     $(MAKE)
37    
38     # the build should fail if the tests are not successful
39     #$(MAKE) check
40    
41 schoenebeck 313 # generate Doxygen API documentation
42     $(MAKE) docs
43    
44 schoenebeck 186 touch build-stamp
45    
46     clean:
47     dh_testdir
48     dh_testroot
49     rm -f build-stamp
50    
51 flax 440 $(MAKE) -f Makefile.cvs
52     ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
53    
54    
55 schoenebeck 186 # Add here commands to clean up after the build process.
56     -$(MAKE) distclean
57    
58     dh_clean -a
59    
60     install: build
61     dh_testdir
62     dh_testroot
63     dh_clean -k -a
64     dh_installdirs
65    
66     # Add here commands to install the package into debian/tmp
67     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
68    
69     # Build architecture-independent files here.
70     binary-indep: build install
71     # We have nothing to do by default.
72    
73     # Build architecture-dependent files here.
74     binary-arch: build install
75     dh_testdir
76     dh_testroot
77     dh_install -a --list-missing
78     dh_installchangelogs -a ChangeLog
79     dh_installdocs -a
80     # dh_installexamples
81     # dh_installmenu
82     # dh_installdebconf
83     # dh_installlogrotate
84     # dh_installemacsen
85     # dh_installpam
86     # dh_installmime
87     # dh_installinit
88     # dh_installcron
89     # dh_installinfo
90     dh_installman
91     # dh_link
92     dh_strip -a
93     dh_compress -a
94     dh_fixperms -a
95     # dh_perl
96     # dh_python
97     dh_makeshlibs -plibgig
98     dh_installdeb -a
99     dh_shlibdeps -plibgig
100     dh_shlibdeps -pgigtools -ldebian/tmp/usr/lib
101     dh_gencontrol -a
102     dh_md5sums -a
103     dh_builddeb -a
104    
105     binary: binary-indep binary-arch
106     .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC