/[svn]/liblscp/trunk/debian/rules
ViewVC logotype

Annotation of /liblscp/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2868 - (hide annotations) (download)
Wed Apr 6 19:25:51 2016 UTC (8 years ago) by schoenebeck
File size: 2361 byte(s)
* Debian packaging: Updated to compat 7 (was 4), and assigned
  linuxsampler-devel@lists.sourceforge.net as maintainer of this package.

1 schoenebeck 197 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # GNU copyright 1997 to 1999 by Joey Hess.
5    
6     # Uncomment this to turn on verbose mode.
7     #export DH_VERBOSE=1
8    
9     # These are used for cross-compiling and for saving the configure script
10     # from having to guess our platform (since we know it already)
11     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13    
14    
15     ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
16     CFLAGS += -g
17     endif
18     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
19     INSTALL_PROGRAM += -s
20     endif
21    
22     config.status: configure
23     dh_testdir
24     # Add here commands to configure the package.
25 flax 598 chmod a+x ./configure
26 schoenebeck 197 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
27    
28    
29     build: build-stamp
30     build-stamp: config.status
31     dh_testdir
32    
33     # Add here commands to compile the package.
34     $(MAKE)
35    
36     # the build should fail if the tests are not successful
37     #$(MAKE) check
38    
39     touch build-stamp
40    
41     clean:
42     dh_testdir
43     dh_testroot
44     rm -f build-stamp
45    
46 capela 2095 $(MAKE) -f Makefile.svn || true
47 flax 598 chmod a+x ./configure
48 flax 480 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
49    
50 schoenebeck 197 # Add here commands to clean up after the build process.
51     -$(MAKE) distclean
52    
53     dh_clean -a
54    
55     install: build
56     dh_testdir
57     dh_testroot
58     dh_clean -k -a
59     dh_installdirs
60    
61     # Add here commands to install the package into debian/tmp
62     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
63    
64     # Build architecture-independent files here.
65     binary-indep: build install
66     # We have nothing to do by default.
67    
68     # Build architecture-dependent files here.
69     binary-arch: build install
70     dh_testdir
71     dh_testroot
72     dh_install -a --list-missing
73     dh_installchangelogs -a ChangeLog
74     dh_installdocs -a
75     # dh_installexamples
76     # dh_installmenu
77     # dh_installdebconf
78     # dh_installlogrotate
79     # dh_installemacsen
80     # dh_installpam
81     # dh_installmime
82     # dh_installinit
83     # dh_installcron
84     # dh_installinfo
85     # dh_installman
86     # dh_link
87     dh_strip -a
88     dh_compress -a
89     dh_fixperms -a
90     # dh_perl
91     # dh_python
92 capela 2122 dh_makeshlibs
93     dh_installdeb
94     dh_shlibdeps
95     dh_gencontrol
96     dh_md5sums
97     dh_builddeb
98 schoenebeck 197
99     binary: binary-indep binary-arch
100     .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC