/[svn]/liblscp/trunk/debian/rules
ViewVC logotype

Annotation of /liblscp/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 954 - (hide annotations) (download)
Tue Nov 28 23:36:05 2006 UTC (17 years, 4 months ago) by schoenebeck
File size: 2467 byte(s)
- minor Debian packaging fix and preparation for release 0.4.1

1 schoenebeck 197 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # GNU copyright 1997 to 1999 by Joey Hess.
5    
6     # Uncomment this to turn on verbose mode.
7     #export DH_VERBOSE=1
8    
9     # This is the debhelper compatibility version to use.
10     export DH_COMPAT=4
11    
12     # These are used for cross-compiling and for saving the configure script
13     # from having to guess our platform (since we know it already)
14     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
15     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16    
17    
18     ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
19     CFLAGS += -g
20     endif
21     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22     INSTALL_PROGRAM += -s
23     endif
24    
25     config.status: configure
26     dh_testdir
27     # Add here commands to configure the package.
28 flax 598 chmod a+x ./configure
29 schoenebeck 197 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
30    
31    
32     build: build-stamp
33     build-stamp: config.status
34     dh_testdir
35    
36     # Add here commands to compile the package.
37     $(MAKE)
38    
39     # the build should fail if the tests are not successful
40     #$(MAKE) check
41    
42     touch build-stamp
43    
44     clean:
45     dh_testdir
46     dh_testroot
47     rm -f build-stamp
48    
49 schoenebeck 954 $(MAKE) -f Makefile.cvs || true
50 flax 598 chmod a+x ./configure
51 flax 480 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
52    
53 schoenebeck 197 # Add here commands to clean up after the build process.
54     -$(MAKE) distclean
55    
56     dh_clean -a
57    
58     install: build
59     dh_testdir
60     dh_testroot
61     dh_clean -k -a
62     dh_installdirs
63    
64     # Add here commands to install the package into debian/tmp
65     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
66    
67     # Build architecture-independent files here.
68     binary-indep: build install
69     # We have nothing to do by default.
70    
71     # Build architecture-dependent files here.
72     binary-arch: build install
73     dh_testdir
74     dh_testroot
75     dh_install -a --list-missing
76     dh_installchangelogs -a ChangeLog
77     dh_installdocs -a
78     # dh_installexamples
79     # dh_installmenu
80     # dh_installdebconf
81     # dh_installlogrotate
82     # dh_installemacsen
83     # dh_installpam
84     # dh_installmime
85     # dh_installinit
86     # dh_installcron
87     # dh_installinfo
88     # dh_installman
89     # dh_link
90     dh_strip -a
91     dh_compress -a
92     dh_fixperms -a
93     # dh_perl
94     # dh_python
95     dh_makeshlibs -pliblscp
96     dh_installdeb -a
97     dh_shlibdeps -pliblscp
98     dh_gencontrol -a
99     dh_md5sums -a
100     dh_builddeb -a
101    
102     binary: binary-indep binary-arch
103     .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC