/[svn]/liblscp/trunk/rpm/liblscp.spec
ViewVC logotype

Annotation of /liblscp/trunk/rpm/liblscp.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 4047 - (hide annotations) (download)
Mon Oct 3 08:51:11 2022 UTC (17 months, 3 weeks ago) by capela
File size: 7639 byte(s)
* An Early-Autumn'22 Release (v0.9.7)
1 capela 4045 #
2     # spec file for package liblscp
3     #
4     # Copyright (C) 2004-2022, rncbc aka Rui Nuno Capela. All rights reserved.
5     # Copyright (C) 2007,2008,2015 Christian Schoenebeck
6     #
7     # All modifications and additions to the file contributed by third parties
8     # remain the property of their copyright owners, unless otherwise agreed
9     # upon. The license for this file, and modifications and additions to the
10     # file, is the same license as for the pristine package itself (unless the
11     # license for the pristine package is not an Open Source License, in which
12     # case the license is the MIT License). An "Open Source License" is a
13     # license that conforms to the Open Source Definition (Version 1.9)
14     # published by the Open Source Initiative.
15     #
16     # Please submit bugfixes or comments via http://bugs.opensuse.org/
17     #
18    
19     %define name liblscp
20 capela 4047 %define version 0.9.7
21     %define release 51.1
22 capela 4045
23     %define _soname %{name}6
24    
25     %define _prefix @ac_prefix@
26    
27     %if %{defined fedora}
28     %global debug_package %{nil}
29     %endif
30    
31     Summary: LinuxSampler Control Protocol API library
32     Name: %{name}
33     Version: %{version}
34     Release: %{release}
35     License: LGPL-2.0+
36     Source0: %{name}-%{version}.tar.gz
37     URL: http://www.linuxsampler.org/
38     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
39     #Packager: rncbc.org
40    
41     BuildRequires: coreutils
42     BuildRequires: cmake
43     BuildRequires: pkgconfig
44     BuildRequires: glibc-devel
45     BuildRequires: doxygen
46    
47     %description
48     LinuxSampler control protocol API library.
49    
50    
51     %package -n %{_soname}
52     Summary: LinuxSampler Control Protocol API library
53     Group: System/Libraries
54     Provides: %{name}
55    
56     %description -n %{_soname}
57     LinuxSampler Control Protocol C API library - development files.
58     .
59     This package is for use with the LinuxSampler audio sampling
60     engine / library and packages. Wraps the LinuxSampler network
61     protocol and offers a convenient API in form of a C library.
62     .
63     For further informations visit
64     http://www.linuxsampler.org
65     .
66     This package contains the header files needed for
67     development with liblscp. You will need this only if you
68     intend to compile programs that use this library.
69    
70    
71     %package devel
72     Summary: LinuxSampler Control Protocol API library - development files
73     Group: Development/Libraries/C and C++
74     Requires: pkgconfig
75     Requires: %{name} >= %{version}
76    
77     %description devel
78     LinuxSampler Control Protocol C API library - development files.
79    
80     This package is for use with the LinuxSampler audio sampling
81     engine / library and packages. Wraps the LinuxSampler network
82     protocol and offers a convenient API in form of a C library.
83    
84     For further informations visit
85     http://www.linuxsampler.org
86    
87     This package contains the header files needed for
88     development with liblscp. You will need this only if you
89     intend to compile programs that use this library.
90    
91    
92     %prep
93     %setup -q
94    
95     %build
96     cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
97     cmake --build build %{?_smp_mflags}
98    
99     %install
100     DESTDIR="%{buildroot}" \
101     cmake --install build
102    
103     %clean
104     [ -d "%{buildroot}" -a "%{buildroot}" != "/" ] && %__rm -rf "%{buildroot}"
105    
106     %post -n %{_soname}
107     /sbin/ldconfig
108    
109     %postun -n %{_soname}
110     /sbin/ldconfig
111    
112     %files -n %{_soname}
113     %defattr(-,root,root)
114     %doc README LICENSE ChangeLog
115     %{_libdir}/liblscp.so.*
116    
117     %files devel
118     %defattr(-,root,root)
119     %{_libdir}/liblscp.so
120     %{_libdir}/pkgconfig/lscp.pc
121     %dir %{_includedir}/lscp
122     %{_includedir}/lscp/*.h
123     %dir %{_datadir}/doc/%{name}
124     %dir %{_datadir}/doc/%{name}/html
125     %{_datadir}/doc/%{name}/html/*
126    
127    
128     %changelog
129 capela 4047 * Mon Oct 3 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
130     - An Early-Autumn'22 Release.
131 capela 4045 * Sat Apr 2 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
132     - A Spring'22 Release.
133     * Sun Jan 9 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
134     - A Winter'22 Release.
135     * Sun Jul 4 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
136     - Early-Summer'21 release.
137     * Tue May 11 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
138     - Spring'21 release.
139     * Sun Mar 14 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
140     - End-of-Winter'21 release.
141     * Sun Feb 7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
142     - Winter'21 release.
143     * Thu Dec 17 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
144     - Winter'20 release.
145     * Tue Mar 24 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.2
146     - Spring'20 release.
147     * Sun Dec 22 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.1
148     - Winter'19 release.
149     * Tue Dec 12 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.6.0
150     - Autumn'17 release: bumped directly to 0.6.0.
151     * Mon Nov 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.5.8
152     - Fall'16 release.
153     * Tue Dec 31 2013 Rui Nuno Capela <rncbc@rncbc.org> 0.5.7
154     - A fifth of a Jubilee release.
155     * Sun Feb 24 2013 Rui Nuno Capela <rncbc@rncbc.org>
156     - Use getaddrinfo() instead of deprecated gethostbyname().
157     * Sat Aug 1 2009 Rui Nuno Capela <rncbc@rncbc.org> 0.5.6
158     - New 0.5.6 release.
159     * Fri Oct 12 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.5
160     - Changed client interface function, for editing channel instrument.
161     - New 0.5.5 release.
162     * Tue Oct 2 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.4
163     - Added new client interface function, for editing instrument.
164     - New 0.5.4 release.
165     * Mon Jan 15 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.3
166     - New 0.5.3 release.
167     * Thu Jan 11 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.2
168     - Sampler channel effect sends control and global volume support.
169     - Audio routing representation changed to integer array.
170     - New 0.5.2 release.
171     * Fri Dec 22 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.5.1
172     - Added support for new (un)subscribable events.
173     - Examples update.
174     - Prepared for 0.5.1 maintenance release.
175     * Sun Dec 17 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.5.0
176     - Multi MIDI instrument maps introduced, sampler channel assignable.
177     - Moved on up to a brand new 0.5.0 release.
178     * Mon Dec 4 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.4.2
179     - Going up to 0.4.2 fast.
180     * Tue Nov 28 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.4.1
181     - Bumped directly to 0.4.1 release.
182     - Getting ready for the new MIDI instrument mapping features.
183     * Thu Jun 1 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.3.3
184     - Take a chance for a new 0.3.3 release.
185     - Changed deprecated copyright attribute to license.
186     - Added ldconfig to post-(un)install steps.
187     * Mon Aug 29 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.2
188     - Fixed for 0.3.2 release.
189     * Wed Aug 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.1
190     - Prepare 0.3.1 release for sampler channel mute/solo support.
191     * Fri Jun 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.0
192     - Prepare 0.3.0 release featuring timeout flush idiosyncrasies.
193     * Sun May 22 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.9
194     - Prepare 0.2.9 release due to event subscription LSCP command changes.
195     * Fri May 6 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.8
196     - Prepare 0.2.8 release in response to [bug #9].
197     * Thu Mar 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.7
198     - Prepare 0.2.7 yet another bug-fix release.
199     * Tue Mar 1 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.6
200     - Prepare 0.2.6 bug-fix release.
201     * Mon Feb 14 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.5
202     - Prepare 0.2.5 release.
203     * Mon Oct 11 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.4
204     - Fixed 0.2.4 release.
205     * Tue Sep 28 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.3
206     - Fixed 0.2.3 release.
207     * Thu Jul 29 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
208     - Prepare 0.2.2 release.
209     * Tue Jul 13 2004 Christian Schoenebeck <cuse@users.sourceforge.net>
210     - renamed 'liblscp.pc' to 'lscp.pc' as well as the pkg-config lib name
211     * Thu Jul 8 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.1
212     - Prepare 0.2.1 bugfix release.
213     * Tue Jul 6 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
214     - Catch up on 0.2.0 release.
215     * Mon Apr 26 2004 Rui Nuno Capela <rncbc@rncbc.org>
216     - Server stuff moved out (stays on examples source package)
217     * Sat Apr 24 2004 Rui Nuno Capela <rncbc@rncbc.org>
218     - Created initial liblscp.spec.in

  ViewVC Help
Powered by ViewVC