/[svn]/liblscp/trunk/rpm/liblscp.spec
ViewVC logotype

Contents of /liblscp/trunk/rpm/liblscp.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 4112 - (show annotations) (download)
Wed May 1 09:56:53 2024 UTC (5 weeks, 4 days ago) by capela
File size: 7919 byte(s)
* A Spring'24 Release Candidate 2 (aka. v1.0.0-rc2)
1 #
2 # spec file for package liblscp
3 #
4 # Copyright (C) 2004-2024, rncbc aka Rui Nuno Capela. All rights reserved.
5 # Copyright (C) 2007,2008,2015 Christian Schoenebeck
6 #
7 # All modifications and additions to the file contributed by third parties
8 # remain the property of their copyright owners, unless otherwise agreed
9 # upon. The license for this file, and modifications and additions to the
10 # file, is the same license as for the pristine package itself (unless the
11 # license for the pristine package is not an Open Source License, in which
12 # case the license is the MIT License). An "Open Source License" is a
13 # license that conforms to the Open Source Definition (Version 1.9)
14 # published by the Open Source Initiative.
15
16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
17 #
18
19 Summary: LinuxSampler Control Protocol API library
20 Name: liblscp
21 Version: 0.9.91
22 Release: 1.1
23 License: LGPL-2.0-or-later
24 Source: %{name}-%{version}.tar.gz
25 URL: https://www.linuxsampler.org/
26 #Packager: rncbc.org
27
28 %define sover 6
29
30 BuildRequires: coreutils
31 BuildRequires: pkgconfig
32 BuildRequires: glibc-devel
33 BuildRequires: cmake >= 3.15
34 BuildRequires: doxygen
35
36 %description
37 LinuxSampler control protocol API library.
38
39
40 %package -n %{name}%{sover}
41 Summary: LinuxSampler Control Protocol API library
42 Group: System/Libraries
43 Provides: %{name}
44
45 %description -n %{name}%{sover}
46 This package is for use with the LinuxSampler audio sampling
47 engine / library and packages. Wraps the LinuxSampler network
48 protocol and offers a convenient API in form of a C library.
49
50 For further informations visit
51 https://www.linuxsampler.org
52
53 This package contains the header files needed for
54 development with liblscp. You will need this only if you
55 intend to compile programs that use this library.
56
57
58 %package devel
59 Summary: LinuxSampler Control Protocol API library - development files
60 Group: Development/Libraries/C and C++
61 Requires: pkgconfig
62 Requires: %{name}%{sover} = %{version}
63
64 %description devel
65 This package is for use with the LinuxSampler audio sampling
66 engine / library and packages. Wraps the LinuxSampler network
67 protocol and offers a convenient API in form of a C library.
68
69 For further informations visit
70 https://www.linuxsampler.org
71
72 This package contains the header files needed for
73 development with liblscp. You will need this only if you
74 intend to compile programs that use this library.
75
76
77 %prep
78 %setup -q
79
80 %build
81 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
82 cmake --build build %{?_smp_mflags}
83
84 %install
85 DESTDIR="%{buildroot}" \
86 cmake --install build
87
88 %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
89 %post -n %{name}%{sover} -p /sbin/ldconfig
90 %postun -n %{name}%{sover} -p /sbin/ldconfig
91 %else
92 %ldconfig_scriptlets -n %{name}%{sover}
93 %endif
94
95
96 %files -n %{name}%{sover}
97 %license LICENSE
98 %{_libdir}/liblscp.so.%{sover}
99 %{_libdir}/liblscp.so.%{sover}.*
100
101 %files devel
102 %{_libdir}/liblscp.so
103 %{_libdir}/pkgconfig/lscp.pc
104 %dir %{_includedir}/lscp
105 %{_includedir}/lscp/*.h
106 %dir %{_datadir}/doc/%{name}
107 %dir %{_datadir}/doc/%{name}/html
108 %{_datadir}/doc/%{name}/html/*
109
110
111 %changelog
112 * Wed May 1 2024 Rui Nuno Capela <rncbc@rncbc.org> 0.9.91
113 - A Spring'24 Release Candidate 2.
114 * Wed Apr 10 2024 Rui Nuno Capela <rncbc@rncbc.org> 0.9.90
115 - A Spring'24 Release Candidate.
116 * Wed Jan 24 2024 Rui Nuno Capela <rncbc@rncbc.org> 0.9.12
117 - A Winter'24 Release.
118 * Sat Sep 9 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.11
119 - An End-of-Summer'23 Release.
120 * Thu Jun 1 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.10
121 - A Spring'23 Release.
122 * Thu Mar 23 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.9
123 - An Early-Spring'23 Release.
124 * Wed Dec 28 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.8
125 - An End-of-Year'22 Release.
126 * Mon Oct 3 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
127 - An Early-Autumn'22 Release.
128 * Sat Apr 2 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
129 - A Spring'22 Release.
130 * Sun Jan 9 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
131 - A Winter'22 Release.
132 * Sun Jul 4 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
133 - Early-Summer'21 release.
134 * Tue May 11 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
135 - Spring'21 release.
136 * Sun Mar 14 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
137 - End-of-Winter'21 release.
138 * Sun Feb 7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
139 - Winter'21 release.
140 * Thu Dec 17 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
141 - Winter'20 release.
142 * Tue Mar 24 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.2
143 - Spring'20 release.
144 * Sun Dec 22 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.1
145 - Winter'19 release.
146 * Tue Dec 12 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.6.0
147 - Autumn'17 release: bumped directly to 0.6.0.
148 * Mon Nov 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.5.8
149 - Fall'16 release.
150 * Tue Dec 31 2013 Rui Nuno Capela <rncbc@rncbc.org> 0.5.7
151 - A fifth of a Jubilee release.
152 * Sun Feb 24 2013 Rui Nuno Capela <rncbc@rncbc.org>
153 - Use getaddrinfo() instead of deprecated gethostbyname().
154 * Sat Aug 1 2009 Rui Nuno Capela <rncbc@rncbc.org> 0.5.6
155 - New 0.5.6 release.
156 * Fri Oct 12 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.5
157 - Changed client interface function, for editing channel instrument.
158 - New 0.5.5 release.
159 * Tue Oct 2 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.4
160 - Added new client interface function, for editing instrument.
161 - New 0.5.4 release.
162 * Mon Jan 15 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.3
163 - New 0.5.3 release.
164 * Thu Jan 11 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.2
165 - Sampler channel effect sends control and global volume support.
166 - Audio routing representation changed to integer array.
167 - New 0.5.2 release.
168 * Fri Dec 22 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.5.1
169 - Added support for new (un)subscribable events.
170 - Examples update.
171 - Prepared for 0.5.1 maintenance release.
172 * Sun Dec 17 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.5.0
173 - Multi MIDI instrument maps introduced, sampler channel assignable.
174 - Moved on up to a brand new 0.5.0 release.
175 * Mon Dec 4 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.4.2
176 - Going up to 0.4.2 fast.
177 * Tue Nov 28 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.4.1
178 - Bumped directly to 0.4.1 release.
179 - Getting ready for the new MIDI instrument mapping features.
180 * Thu Jun 1 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.3.3
181 - Take a chance for a new 0.3.3 release.
182 - Changed deprecated copyright attribute to license.
183 - Added ldconfig to post-(un)install steps.
184 * Mon Aug 29 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.2
185 - Fixed for 0.3.2 release.
186 * Wed Aug 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.1
187 - Prepare 0.3.1 release for sampler channel mute/solo support.
188 * Fri Jun 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.0
189 - Prepare 0.3.0 release featuring timeout flush idiosyncrasies.
190 * Sun May 22 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.9
191 - Prepare 0.2.9 release due to event subscription LSCP command changes.
192 * Fri May 6 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.8
193 - Prepare 0.2.8 release in response to [bug #9].
194 * Thu Mar 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.7
195 - Prepare 0.2.7 yet another bug-fix release.
196 * Tue Mar 1 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.6
197 - Prepare 0.2.6 bug-fix release.
198 * Mon Feb 14 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.5
199 - Prepare 0.2.5 release.
200 * Mon Oct 11 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.4
201 - Fixed 0.2.4 release.
202 * Tue Sep 28 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.3
203 - Fixed 0.2.3 release.
204 * Thu Jul 29 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
205 - Prepare 0.2.2 release.
206 * Tue Jul 13 2004 Christian Schoenebeck <cuse@users.sourceforge.net>
207 - renamed 'liblscp.pc' to 'lscp.pc' as well as the pkg-config lib name
208 * Thu Jul 8 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.1
209 - Prepare 0.2.1 bugfix release.
210 * Tue Jul 6 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
211 - Catch up on 0.2.0 release.
212 * Mon Apr 26 2004 Rui Nuno Capela <rncbc@rncbc.org>
213 - Server stuff moved out (stays on examples source package)
214 * Sat Apr 24 2004 Rui Nuno Capela <rncbc@rncbc.org>
215 - Created initial liblscp.spec.in

  ViewVC Help
Powered by ViewVC