/[svn]/liblscp/trunk/rpm/liblscp.spec
ViewVC logotype

Annotation of /liblscp/trunk/rpm/liblscp.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 4110 - (hide annotations) (download)
Wed Apr 10 15:14:49 2024 UTC (2 weeks ago) by capela
File size: 8173 byte(s)
* A Spring'24 Release Candidate (aka. v1.0.0-rc1)
1 capela 4045 #
2     # spec file for package liblscp
3     #
4 capela 4069 # Copyright (C) 2004-2024, rncbc aka Rui Nuno Capela. All rights reserved.
5 capela 4045 # Copyright (C) 2007,2008,2015 Christian Schoenebeck
6     #
7     # All modifications and additions to the file contributed by third parties
8     # remain the property of their copyright owners, unless otherwise agreed
9     # upon. The license for this file, and modifications and additions to the
10     # file, is the same license as for the pristine package itself (unless the
11     # license for the pristine package is not an Open Source License, in which
12     # case the license is the MIT License). An "Open Source License" is a
13     # license that conforms to the Open Source Definition (Version 1.9)
14     # published by the Open Source Initiative.
15     #
16     # Please submit bugfixes or comments via http://bugs.opensuse.org/
17     #
18    
19 capela 4069 %define name liblscp
20 capela 4110 %define version 0.9.90
21     %define release 1.1
22 capela 4045
23     %define _soname %{name}6
24    
25 capela 4049 %define _prefix /usr
26 capela 4045
27     %if %{defined fedora}
28     %global debug_package %{nil}
29     %endif
30    
31     Summary: LinuxSampler Control Protocol API library
32     Name: %{name}
33     Version: %{version}
34     Release: %{release}
35     License: LGPL-2.0+
36     Source0: %{name}-%{version}.tar.gz
37     URL: http://www.linuxsampler.org/
38     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
39     #Packager: rncbc.org
40    
41     BuildRequires: coreutils
42     BuildRequires: pkgconfig
43     BuildRequires: glibc-devel
44 capela 4051 BuildRequires: cmake >= 3.15
45 capela 4045 BuildRequires: doxygen
46    
47     %description
48     LinuxSampler control protocol API library.
49    
50    
51     %package -n %{_soname}
52     Summary: LinuxSampler Control Protocol API library
53     Group: System/Libraries
54     Provides: %{name}
55    
56     %description -n %{_soname}
57     LinuxSampler Control Protocol C API library - development files.
58     .
59     This package is for use with the LinuxSampler audio sampling
60     engine / library and packages. Wraps the LinuxSampler network
61     protocol and offers a convenient API in form of a C library.
62     .
63     For further informations visit
64     http://www.linuxsampler.org
65     .
66     This package contains the header files needed for
67     development with liblscp. You will need this only if you
68     intend to compile programs that use this library.
69    
70    
71     %package devel
72     Summary: LinuxSampler Control Protocol API library - development files
73     Group: Development/Libraries/C and C++
74     Requires: pkgconfig
75     Requires: %{name} >= %{version}
76    
77     %description devel
78     LinuxSampler Control Protocol C API library - development files.
79    
80     This package is for use with the LinuxSampler audio sampling
81     engine / library and packages. Wraps the LinuxSampler network
82     protocol and offers a convenient API in form of a C library.
83    
84     For further informations visit
85     http://www.linuxsampler.org
86    
87     This package contains the header files needed for
88     development with liblscp. You will need this only if you
89     intend to compile programs that use this library.
90    
91    
92     %prep
93     %setup -q
94    
95     %build
96     cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
97     cmake --build build %{?_smp_mflags}
98    
99     %install
100     DESTDIR="%{buildroot}" \
101     cmake --install build
102    
103     %clean
104     [ -d "%{buildroot}" -a "%{buildroot}" != "/" ] && %__rm -rf "%{buildroot}"
105    
106     %post -n %{_soname}
107     /sbin/ldconfig
108    
109     %postun -n %{_soname}
110     /sbin/ldconfig
111    
112     %files -n %{_soname}
113     %defattr(-,root,root)
114 capela 4055 %license LICENSE
115     %doc README ChangeLog
116 capela 4045 %{_libdir}/liblscp.so.*
117    
118     %files devel
119     %defattr(-,root,root)
120     %{_libdir}/liblscp.so
121     %{_libdir}/pkgconfig/lscp.pc
122     %dir %{_includedir}/lscp
123     %{_includedir}/lscp/*.h
124     %dir %{_datadir}/doc/%{name}
125     %dir %{_datadir}/doc/%{name}/html
126     %{_datadir}/doc/%{name}/html/*
127    
128    
129     %changelog
130 capela 4110 * Wed Apr 10 2024 Rui Nuno Capela <rncbc@rncbc.org> 0.9.90
131     - A Spring'24 Release Candidate.
132 capela 4073 * Wed Jan 24 2024 Rui Nuno Capela <rncbc@rncbc.org> 0.9.12
133     - A Winter'24 Release.
134 capela 4061 * Sat Sep 9 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.11
135     - An End-of-Summer'23 Release.
136 capela 4059 * Thu Jun 1 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.10
137     - A Spring'23 Release.
138 capela 4055 * Thu Mar 23 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.9
139     - An Early-Spring'23 Release.
140 capela 4053 * Wed Dec 28 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.8
141     - An End-of-Year'22 Release.
142 capela 4047 * Mon Oct 3 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
143     - An Early-Autumn'22 Release.
144 capela 4045 * Sat Apr 2 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
145     - A Spring'22 Release.
146     * Sun Jan 9 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
147     - A Winter'22 Release.
148     * Sun Jul 4 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
149     - Early-Summer'21 release.
150     * Tue May 11 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
151     - Spring'21 release.
152     * Sun Mar 14 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
153     - End-of-Winter'21 release.
154     * Sun Feb 7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
155     - Winter'21 release.
156     * Thu Dec 17 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
157     - Winter'20 release.
158     * Tue Mar 24 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.2
159     - Spring'20 release.
160     * Sun Dec 22 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.1
161     - Winter'19 release.
162     * Tue Dec 12 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.6.0
163     - Autumn'17 release: bumped directly to 0.6.0.
164     * Mon Nov 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.5.8
165     - Fall'16 release.
166     * Tue Dec 31 2013 Rui Nuno Capela <rncbc@rncbc.org> 0.5.7
167     - A fifth of a Jubilee release.
168     * Sun Feb 24 2013 Rui Nuno Capela <rncbc@rncbc.org>
169     - Use getaddrinfo() instead of deprecated gethostbyname().
170     * Sat Aug 1 2009 Rui Nuno Capela <rncbc@rncbc.org> 0.5.6
171     - New 0.5.6 release.
172     * Fri Oct 12 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.5
173     - Changed client interface function, for editing channel instrument.
174     - New 0.5.5 release.
175     * Tue Oct 2 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.4
176     - Added new client interface function, for editing instrument.
177     - New 0.5.4 release.
178     * Mon Jan 15 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.3
179     - New 0.5.3 release.
180     * Thu Jan 11 2007 Rui Nuno Capela <rncbc@rncbc.org> 0.5.2
181     - Sampler channel effect sends control and global volume support.
182     - Audio routing representation changed to integer array.
183     - New 0.5.2 release.
184     * Fri Dec 22 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.5.1
185     - Added support for new (un)subscribable events.
186     - Examples update.
187     - Prepared for 0.5.1 maintenance release.
188     * Sun Dec 17 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.5.0
189     - Multi MIDI instrument maps introduced, sampler channel assignable.
190     - Moved on up to a brand new 0.5.0 release.
191     * Mon Dec 4 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.4.2
192     - Going up to 0.4.2 fast.
193     * Tue Nov 28 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.4.1
194     - Bumped directly to 0.4.1 release.
195     - Getting ready for the new MIDI instrument mapping features.
196     * Thu Jun 1 2006 Rui Nuno Capela <rncbc@rncbc.org> 0.3.3
197     - Take a chance for a new 0.3.3 release.
198     - Changed deprecated copyright attribute to license.
199     - Added ldconfig to post-(un)install steps.
200     * Mon Aug 29 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.2
201     - Fixed for 0.3.2 release.
202     * Wed Aug 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.1
203     - Prepare 0.3.1 release for sampler channel mute/solo support.
204     * Fri Jun 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.3.0
205     - Prepare 0.3.0 release featuring timeout flush idiosyncrasies.
206     * Sun May 22 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.9
207     - Prepare 0.2.9 release due to event subscription LSCP command changes.
208     * Fri May 6 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.8
209     - Prepare 0.2.8 release in response to [bug #9].
210     * Thu Mar 10 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.7
211     - Prepare 0.2.7 yet another bug-fix release.
212     * Tue Mar 1 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.6
213     - Prepare 0.2.6 bug-fix release.
214     * Mon Feb 14 2005 Rui Nuno Capela <rncbc@rncbc.org> 0.2.5
215     - Prepare 0.2.5 release.
216     * Mon Oct 11 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.4
217     - Fixed 0.2.4 release.
218     * Tue Sep 28 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.3
219     - Fixed 0.2.3 release.
220     * Thu Jul 29 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
221     - Prepare 0.2.2 release.
222     * Tue Jul 13 2004 Christian Schoenebeck <cuse@users.sourceforge.net>
223     - renamed 'liblscp.pc' to 'lscp.pc' as well as the pkg-config lib name
224     * Thu Jul 8 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.1
225     - Prepare 0.2.1 bugfix release.
226     * Tue Jul 6 2004 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
227     - Catch up on 0.2.0 release.
228     * Mon Apr 26 2004 Rui Nuno Capela <rncbc@rncbc.org>
229     - Server stuff moved out (stays on examples source package)
230     * Sat Apr 24 2004 Rui Nuno Capela <rncbc@rncbc.org>
231     - Created initial liblscp.spec.in

  ViewVC Help
Powered by ViewVC