/[svn]/linuxsampler/trunk/debian/rules
ViewVC logotype

Annotation of /linuxsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 599 - (hide annotations) (download)
Thu Jun 2 08:33:40 2005 UTC (18 years, 11 months ago) by flax
File size: 2420 byte(s)
* multiport and control file fixes

1 schoenebeck 375 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     #export DH_VERBOSE=1
11    
12     CFLAGS = -Wall -g
13    
14     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15     CFLAGS += -O0
16     else
17     CFLAGS += -O2
18     endif
19    
20     configure: configure-stamp
21     configure-stamp:
22     dh_testdir
23     # Add here commands to configure the package.
24     $(MAKE) -f Makefile.cvs
25 flax 591 chmod a+x configure
26 schoenebeck 375 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
27     touch configure-stamp
28    
29    
30     build: build-stamp
31    
32     build-stamp: configure-stamp
33     dh_testdir
34    
35     # Add here commands to compile the package.
36     $(MAKE)
37 flax 591 # docbook-to-man debian/linuxsampler.sgml > linuxsampler.1
38 schoenebeck 375
39 flax 591 # $(MAKE)
40    
41 schoenebeck 375 touch build-stamp
42    
43     clean:
44     dh_testdir
45     dh_testroot
46     rm -f build-stamp configure-stamp
47    
48 flax 599 -$(MAKE) -f Makefile.cvs
49 schoenebeck 375 # Add here commands to clean up after the build process.
50 flax 599 chmod a+x configure
51     ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
52    
53 schoenebeck 375 -$(MAKE) distclean
54    
55     dh_clean
56    
57     install: build
58     dh_testdir
59     dh_testroot
60     dh_clean -k
61     dh_installdirs
62    
63     # Add here commands to install the package into debian/linuxsampler.
64     $(MAKE) install DESTDIR=$(CURDIR)/debian/linuxsampler
65    
66    
67     # Build architecture-independent files here.
68     binary-indep: build install
69     # We have nothing to do by default.
70    
71     # Build architecture-dependent files here.
72     binary-arch: build install
73     dh_testdir
74     dh_testroot
75     dh_installchangelogs
76     dh_installdocs
77     dh_installexamples
78     # dh_install
79     # dh_installmenu
80     # dh_installdebconf
81     # dh_installlogrotate
82     # dh_installemacsen
83     # dh_installpam
84     # dh_installmime
85     # dh_installinit
86     # dh_installcron
87     # dh_installinfo
88 flax 599 dh_installman man/linuxsampler.1.in
89 schoenebeck 375 dh_link
90     dh_strip
91     dh_compress
92     dh_fixperms
93     # dh_perl
94     # dh_python
95     # dh_makeshlibs
96     dh_installdeb
97 flax 591 dh_shlibdeps # -L linuxsampler -l debian/linuxsampler/usr/lib/linuxsampler
98 schoenebeck 375 dh_gencontrol
99     dh_md5sums
100     dh_builddeb
101    
102     binary: binary-indep binary-arch
103     .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC