/[svn]/qsampler/trunk/debian/rules
ViewVC logotype

Contents of /qsampler/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 3516 - (show annotations) (download)
Tue Jun 18 07:49:48 2019 UTC (4 years, 10 months ago) by capela
File size: 1664 byte(s)
- Configure updated to check for qtchooser availability.
1 #!/usr/bin/make -f
2 APPNAME := qsampler
3
4 # Uncomment this to turn on verbose mode.
5 #export DH_VERBOSE=1
6
7 # This is the debhelper compatibility version to use.
8 #export DH_COMPAT=4
9
10 configure: configure-stamp
11 configure-stamp:
12 dh_testdir
13
14 # Add here commands to configure the package.
15 ./autogen.sh
16
17 ./configure --prefix=/usr
18 # --- end custom part for configure
19
20 touch configure-stamp
21
22 build: build-stamp
23 build-stamp: configure-stamp
24 dh_testdir
25
26 # Add here commands to compile the package.
27 $(MAKE)
28 # --- end custom part for compiling
29
30 touch build-stamp
31
32 clean:
33 dh_testdir
34 dh_testroot
35 rm -f build-stamp configure-stamp
36
37 # Add here commands to clean up after the build process.
38 ./autogen.sh clean
39 # --- end custom part for cleaning up
40
41 dh_clean
42
43 install: build
44 dh_testdir
45 dh_testroot
46 dh_clean -k
47 dh_installdirs
48
49 # Add here commands to install the package
50 $(MAKE) install DESTDIR=$(CURDIR)/debian/$(APPNAME)
51 # --- end custom part for installing
52
53 # Build architecture-independent files here.
54 binary-indep: build install
55 # We have nothing to do by default.
56
57 # Build architecture-dependent files here.
58 binary-arch: build install
59 dh_testdir
60 dh_testroot
61 # dh_installdebconf
62 dh_installdocs
63 dh_installexamples
64 dh_installmenu
65 # dh_installlogrotate
66 # dh_installemacsen
67 # dh_installpam
68 # dh_installmime
69 # dh_installinit
70 dh_installcron
71 dh_installman
72 dh_installinfo
73 # dh_undocumented
74 dh_installchangelogs
75 dh_link
76 dh_strip
77 dh_compress
78 dh_fixperms
79 # dh_makeshlibs
80 dh_installdeb
81 # dh_perl
82 dh_shlibdeps
83 dh_gencontrol
84 dh_md5sums
85 dh_builddeb
86
87 binary: binary-indep binary-arch
88 .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC