/[svn]/qsampler/trunk/qsampler.spec.in
ViewVC logotype

Diff of /qsampler/trunk/qsampler.spec.in

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 4043 by capela, Sat Jul 9 21:20:40 2022 UTC revision 4044 by capela, Wed Aug 31 08:02:30 2022 UTC
# Line 26  Line 26 
26  %define debug_package %{nil}  %define debug_package %{nil}
27  %endif  %endif
28    
29  %if 0%{?fedora_version} >= 34 || 0%{?suse_version} > 1500  %if 0%{?fedora_version} >= 34 || 0%{?suse_version} > 1500 || ( 0%{?sle_version} == 150200 && 0%{?is_opensuse} )
30  %define qt_major_version  6  %define qt_major_version  6
31  %else  %else
32  %define qt_major_version  5  %define qt_major_version  5
# Line 47  BuildRoot:     %{_tmppath}/%{name}-%{version Line 47  BuildRoot:     %{_tmppath}/%{name}-%{version
47  BuildRequires:  coreutils  BuildRequires:  coreutils
48  BuildRequires:  pkgconfig  BuildRequires:  pkgconfig
49  BuildRequires:  glibc-devel  BuildRequires:  glibc-devel
50  BuildRequires:  gcc-c++  
51  BuildRequires:  cmake  %if %{defined fedora} || 0%{?suse_version} > 1500
52    BuildRequires:  gcc-c++ >= 8
53    %define CXX             /usr/bin/g++
54    %else
55    BuildRequires:  gcc8-c++ >= 8
56    %define CXX             /usr/bin/g++-8
57    %endif
58    
59    BuildRequires:  cmake >= 3.19
60  %if %{defined fedora}  %if %{defined fedora}
61  %if 0%{qt_major_version} == 6  %if 0%{qt_major_version} == 6
62  BuildRequires:  qt6-qtbase-devel >= 6.1  BuildRequires:  qt6-qtbase-devel >= 6.1
# Line 63  BuildRequires: qt5-linguist Line 71  BuildRequires: qt5-linguist
71  %endif  %endif
72  %else  %else
73  %if 0%{qt_major_version} == 6  %if 0%{qt_major_version} == 6
74    %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
75    BuildRequires:  qtbase6-static >= 6.3
76    BuildRequires:  qttools6-static
77    BuildRequires:  qttranslations6-static
78    BuildRequires:  qtsvg6-static
79    %else
80  BuildRequires:  qt6-base-devel >= 6.1  BuildRequires:  qt6-base-devel >= 6.1
81  BuildRequires:  qt6-tools-devel  BuildRequires:  qt6-tools-devel
82  BuildRequires:  qt6-svg-devel  BuildRequires:  qt6-svg-devel
83  BuildRequires:  qt6-linguist-devel  BuildRequires:  qt6-linguist-devel
84    %endif
85  %else  %else
86  BuildRequires:  libqt5-qtbase-devel >= 5.1  BuildRequires:  libqt5-qtbase-devel >= 5.1
87  BuildRequires:  libqt5-qttools-devel  BuildRequires:  libqt5-qttools-devel
# Line 86  interface of LinuxSampler Control Protoc Line 101  interface of LinuxSampler Control Protoc
101  %setup -q  %setup -q
102    
103  %build  %build
104    %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
105    source /opt/qt6.3-static/bin/qt6.3-static-env.sh
106    %endif
107    CXX=%{CXX} \
108  cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build  cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
109  cmake --build build %{?_smp_mflags}  cmake --build build %{?_smp_mflags}
110    

Legend:
Removed from v.4043  
changed lines
  Added in v.4044

  ViewVC Help
Powered by ViewVC