/[svn]/qsampler/trunk/rpm/qsampler.spec
ViewVC logotype

Annotation of /qsampler/trunk/rpm/qsampler.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 4048 - (hide annotations) (download)
Mon Oct 3 08:51:50 2022 UTC (18 months, 2 weeks ago) by capela
File size: 8505 byte(s)
* An Early-Autumn'22 Release (v0.9.7)
1 capela 4046 #
2     # spec file for package qsampler
3     #
4     # Copyright (C) 2004-2022, rncbc aka Rui Nuno Capela. All rights reserved.
5     # Copyright (C) 2007,2008,2015 Christian Schoenebeck
6     #
7     # All modifications and additions to the file contributed by third parties
8     # remain the property of their copyright owners, unless otherwise agreed
9     # upon. The license for this file, and modifications and additions to the
10     # file, is the same license as for the pristine package itself (unless the
11     # license for the pristine package is not an Open Source License, in which
12     # case the license is the MIT License). An "Open Source License" is a
13     # license that conforms to the Open Source Definition (Version 1.9)
14     # published by the Open Source Initiative.
15     #
16     # Please submit bugfixes or comments via http://bugs.opensuse.org/
17     #
18    
19     %define name qsampler
20 capela 4048 %define version 0.9.7
21     %define release 51.1
22 capela 4046
23     %define _prefix @ac_prefix@
24    
25     %if %{defined fedora}
26     %define debug_package %{nil}
27     %endif
28    
29     %if 0%{?fedora_version} >= 34 || 0%{?suse_version} > 1500 || ( 0%{?sle_version} == 150200 && 0%{?is_opensuse} )
30     %define qt_major_version 6
31     %else
32     %define qt_major_version 5
33     %endif
34    
35     Summary: A LinuxSampler Qt GUI interface
36     Name: %{name}
37     Version: %{version}
38     Release: %{release}
39     License: GPL-2.0+
40     Group: Productivity/Multimedia/Sound/Midi
41     Source0: %{name}-%{version}.tar.gz
42     URL: http://qsampler.sourceforge.net/
43     Packager: rncbc.org
44    
45     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
46    
47     BuildRequires: coreutils
48     BuildRequires: pkgconfig
49     BuildRequires: glibc-devel
50    
51     %if %{defined fedora} || 0%{?suse_version} > 1500
52     BuildRequires: gcc-c++ >= 8
53     %define CXX /usr/bin/g++
54     %else
55     BuildRequires: gcc8-c++ >= 8
56     %define CXX /usr/bin/g++-8
57     %endif
58    
59     BuildRequires: cmake >= 3.19
60     %if %{defined fedora}
61     %if 0%{qt_major_version} == 6
62     BuildRequires: qt6-qtbase-devel >= 6.1
63     BuildRequires: qt6-qttools-devel
64     BuildRequires: qt6-qtsvg-devel
65     BuildRequires: qt6-linguist
66     %else
67     BuildRequires: qt5-qtbase-devel >= 5.1
68     BuildRequires: qt5-qttools-devel
69     BuildRequires: qt5-qtsvg-devel
70     BuildRequires: qt5-linguist
71     %endif
72     %else
73     %if 0%{qt_major_version} == 6
74     %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
75     BuildRequires: qtbase6-static >= 6.3
76     BuildRequires: qttools6-static
77     BuildRequires: qttranslations6-static
78     BuildRequires: qtsvg6-static
79     %else
80     BuildRequires: qt6-base-devel >= 6.1
81     BuildRequires: qt6-tools-devel
82     BuildRequires: qt6-svg-devel
83     BuildRequires: qt6-linguist-devel
84     %endif
85     %else
86     BuildRequires: libqt5-qtbase-devel >= 5.1
87     BuildRequires: libqt5-qttools-devel
88     BuildRequires: libqt5-qtsvg-devel
89     BuildRequires: libqt5-linguist-devel
90     %endif
91     %endif
92     BuildRequires: liblscp-devel >= 0.5.6
93     BuildRequires: libgig-devel >= 3.3.0
94    
95     %description
96     Qsampler is a LinuxSampler GUI front-end application written in C++ around
97     the Qt framework using Qt Designer. For the moment it just wraps the client
98     interface of LinuxSampler Control Protocol (LSCP) (http://www.linuxsampler.org).
99    
100     %prep
101     %setup -q
102    
103     %build
104     %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
105     source /opt/qt6.4-static/bin/qt6.4-static-env.sh
106     %endif
107     CXX=%{CXX} \
108     cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
109     cmake --build build %{?_smp_mflags}
110    
111     %install
112     DESTDIR="%{buildroot}" \
113     cmake --install build
114    
115     %clean
116     [ -d "%{buildroot}" -a "%{buildroot}" != "/" ] && %__rm -rf "%{buildroot}"
117    
118     %files
119     %defattr(-,root,root)
120     %doc README LICENSE TRANSLATORS ChangeLog
121     #dir %{_datadir}/mime
122     #dir %{_datadir}/mime/packages
123     #dir %{_datadir}/applications
124     %dir %{_datadir}/icons/hicolor
125     %dir %{_datadir}/icons/hicolor/32x32
126     %dir %{_datadir}/icons/hicolor/32x32/apps
127     %dir %{_datadir}/icons/hicolor/32x32/mimetypes
128     %dir %{_datadir}/icons/hicolor/scalable
129     %dir %{_datadir}/icons/hicolor/scalable/apps
130     %dir %{_datadir}/icons/hicolor/scalable/mimetypes
131     %dir %{_datadir}/%{name}
132     %dir %{_datadir}/%{name}/translations
133     %dir %{_datadir}/metainfo
134     #dir %{_datadir}/man
135     #dir %{_datadir}/man/man1
136     #dir %{_datadir}/man/fr
137     #dir %{_datadir}/man/fr/man1
138     %{_bindir}/%{name}
139     %{_datadir}/mime/packages/org.rncbc.%{name}.xml
140     %{_datadir}/applications/org.rncbc.%{name}.desktop
141     %{_datadir}/icons/hicolor/32x32/apps/org.rncbc.%{name}.png
142     %{_datadir}/icons/hicolor/scalable/apps/org.rncbc.%{name}.svg
143     %{_datadir}/icons/hicolor/32x32/mimetypes/org.rncbc.%{name}.application-x-%{name}*.png
144     %{_datadir}/icons/hicolor/scalable/mimetypes/org.rncbc.%{name}.application-x-%{name}*.svg
145     %{_datadir}/%{name}/translations/%{name}_*.qm
146     %{_datadir}/metainfo/org.rncbc.%{name}.metainfo.xml
147     %{_datadir}/man/man1/%{name}.1.gz
148     %{_datadir}/man/fr/man1/%{name}.1.gz
149    
150     %changelog
151 capela 4048 * Mon Oct 3 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
152     - An Early-Autumn'22 Release.
153 capela 4046 * Sat Apr 2 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
154     - A Spring'22 Release.
155     * Sun Jan 9 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
156     - A Winter'22 Release.
157     * Sun Jul 4 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
158     - Early-Summer'21 release.
159     * Tue May 11 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
160     - Spring'21 release.
161     * Sun Mar 14 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
162     - End-of-Winter'21 release.
163     * Sun Feb 7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
164     - Winter'21 release.
165     * Thu Dec 17 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
166     - Winter'20 release.
167     * Fri Jul 31 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.3
168     - Summer'20 release.
169     * Tue Mar 24 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.2
170     - Spring'20 release.
171     * Sun Dec 22 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.1
172     - Winter'19 release.
173     * Thu Oct 17 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.0
174     - Autumn'19 release.
175     * Fri Jul 12 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.6
176     - Summer'19 release.
177     * Thu Apr 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.5
178     - Spring-Break'19 release.
179     * Mon Mar 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.4
180     - Pre-LAC2019 release frenzy.
181     * Thu Dec 06 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.3
182     - An End of Autumn'18 Release.
183     * Sun Jul 22 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.2
184     - Summer'18 Release.
185     * Mon May 21 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.1
186     - Pre-LAC2018 release frenzy.
187     * Tue Dec 12 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.5.0
188     - An Autumn'17 release.
189     * Thu Apr 27 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.4.3
190     - Pre-LAC2017 release frenzy.
191     * Mon Nov 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.2
192     - A Fall'16 release.
193     * Wed Sep 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.1
194     - End of Summer'16 release.
195     * Tue Apr 5 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.0
196     - Spring'16 release frenzy.
197     * Sun Jul 19 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.1
198     - Summer'15 release frenzy.
199     * Wed Mar 25 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.0
200     - Pre-LAC2015 release frenzy.
201     * Tue Dec 31 2013 Rui Nuno Capela <rncbc@rncbc.org> 0.2.3
202     - A fifth of a Jubilee release.
203     * Mon May 17 2010 Rui Nuno Capela <rncbc@rncbc.org>
204     - Standard desktop icon fixing.
205     * Sat Aug 1 2009 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
206     - New 0.2.2 release.
207     * Thu Dec 6 2007 Rui Nuno Capela <rncbc@rncbc.org>
208     - Qt4 migration complete.
209     * Mon Jun 25 2007 Rui Nuno Capela <rncbc@rncbc.org>
210     - Application icon is now installed to (prefix)/share/pixmaps.
211     - Declared fundamental build and run-time requirements.
212     - Destination install directory prefix is now in spec.
213     - Spec is now a bit more openSUSE compliant.
214     * Mon Jan 15 2007 Rui Nuno Capela <rncbc@rncbc.org>
215     - Added sampler channel FX send support at session save code-level.
216     - Global sampler volume slider/spinbox combo is now featured.
217     * Sun Dec 17 2006 Rui Nuno Capela <rncbc@rncbc.org>
218     - Added preliminary MIDI instrument mapping support.
219     * Thu Jun 01 2006 Rui Nuno Capela <rncbc@rncbc.org>
220     - Take a chance for a new 0.1.3 release.
221     - Changed deprecated copyright attribute to license.
222     * Wed Aug 24 2005 Rui Nuno Capela <rncbc@rncbc.org>
223     - Prepared auto-generation from configure.
224     * Tue Aug 16 2005 Rui Nuno Capela <rncbc@rncbc.org>
225     - Get in sync with latest offerings from liblscp (0.3.1) and
226     specially libgig (2.0.2) which broke previous ABI, somewhat.
227     * Thu Jun 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
228     - Even minor workings needs a rest.
229     * Mon Jun 13 2005 Rui Nuno Capela <rncbc@rncbc.org>
230     - The mantra of bugfixes.
231     * Mon May 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
232     - Device configuration breakthrough.
233     * Fri Mar 4 2005 Rui Nuno Capela <rncbc@rncbc.org>
234     - Fifth alpha-release.
235     * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
236     - Prepared for the fourth alpha release.
237     * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
238     - Prepared for the fourth alpha release.
239     * Wed Jun 2 2004 Rui Nuno Capela <rncbc@rncbc.org>
240     - Created initial qsampler.spec

  ViewVC Help
Powered by ViewVC