/[svn]/qsampler/trunk/rpm/qsampler.spec
ViewVC logotype

Annotation of /qsampler/trunk/rpm/qsampler.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 4050 - (hide annotations) (download)
Wed Nov 9 18:16:03 2022 UTC (16 months, 2 weeks ago) by capela
File size: 8304 byte(s)
- Update rpm/spec to pkgconfig(Qt*)
1 capela 4046 #
2     # spec file for package qsampler
3     #
4     # Copyright (C) 2004-2022, rncbc aka Rui Nuno Capela. All rights reserved.
5     # Copyright (C) 2007,2008,2015 Christian Schoenebeck
6     #
7     # All modifications and additions to the file contributed by third parties
8     # remain the property of their copyright owners, unless otherwise agreed
9     # upon. The license for this file, and modifications and additions to the
10     # file, is the same license as for the pristine package itself (unless the
11     # license for the pristine package is not an Open Source License, in which
12     # case the license is the MIT License). An "Open Source License" is a
13     # license that conforms to the Open Source Definition (Version 1.9)
14     # published by the Open Source Initiative.
15     #
16     # Please submit bugfixes or comments via http://bugs.opensuse.org/
17     #
18    
19     %define name qsampler
20 capela 4048 %define version 0.9.7
21     %define release 51.1
22 capela 4046
23 capela 4050 %define _prefix /usr
24 capela 4046
25     %if %{defined fedora}
26     %define debug_package %{nil}
27     %endif
28    
29     %if 0%{?fedora_version} >= 34 || 0%{?suse_version} > 1500 || ( 0%{?sle_version} == 150200 && 0%{?is_opensuse} )
30     %define qt_major_version 6
31     %else
32     %define qt_major_version 5
33     %endif
34    
35     Summary: A LinuxSampler Qt GUI interface
36     Name: %{name}
37     Version: %{version}
38     Release: %{release}
39     License: GPL-2.0+
40     Group: Productivity/Multimedia/Sound/Midi
41     Source0: %{name}-%{version}.tar.gz
42     URL: http://qsampler.sourceforge.net/
43     Packager: rncbc.org
44    
45     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
46    
47     BuildRequires: coreutils
48     BuildRequires: pkgconfig
49     BuildRequires: glibc-devel
50    
51     %if %{defined fedora} || 0%{?suse_version} > 1500
52     BuildRequires: gcc-c++ >= 8
53     %define CXX /usr/bin/g++
54     %else
55     BuildRequires: gcc8-c++ >= 8
56     %define CXX /usr/bin/g++-8
57     %endif
58    
59 capela 4050 BuildRequires: cmake >= 3.15
60 capela 4046 %if 0%{qt_major_version} == 6
61     %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
62 capela 4050 BuildRequires: qtbase6-static >= 6.1
63 capela 4046 BuildRequires: qttools6-static
64     BuildRequires: qttranslations6-static
65     BuildRequires: qtsvg6-static
66     %else
67 capela 4050 BuildRequires: cmake(Qt6LinguistTools)
68     BuildRequires: pkgconfig(Qt6Core)
69     BuildRequires: pkgconfig(Qt6Gui)
70     BuildRequires: pkgconfig(Qt6Widgets)
71     BuildRequires: pkgconfig(Qt6Svg)
72     BuildRequires: pkgconfig(Qt6Network)
73 capela 4046 %endif
74     %else
75 capela 4050 BuildRequires: cmake(Qt5LinguistTools)
76     BuildRequires: pkgconfig(Qt5Core)
77     BuildRequires: pkgconfig(Qt5Gui)
78     BuildRequires: pkgconfig(Qt5Widgets)
79     BuildRequires: pkgconfig(Qt5Svg)
80     BuildRequires: pkgconfig(Qt5Network)
81 capela 4046 %endif
82     BuildRequires: liblscp-devel >= 0.5.6
83     BuildRequires: libgig-devel >= 3.3.0
84    
85     %description
86     Qsampler is a LinuxSampler GUI front-end application written in C++ around
87     the Qt framework using Qt Designer. For the moment it just wraps the client
88     interface of LinuxSampler Control Protocol (LSCP) (http://www.linuxsampler.org).
89    
90     %prep
91     %setup -q
92    
93     %build
94     %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
95     source /opt/qt6.4-static/bin/qt6.4-static-env.sh
96     %endif
97     CXX=%{CXX} \
98     cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
99     cmake --build build %{?_smp_mflags}
100    
101     %install
102     DESTDIR="%{buildroot}" \
103     cmake --install build
104    
105     %clean
106     [ -d "%{buildroot}" -a "%{buildroot}" != "/" ] && %__rm -rf "%{buildroot}"
107    
108     %files
109     %defattr(-,root,root)
110     %doc README LICENSE TRANSLATORS ChangeLog
111     #dir %{_datadir}/mime
112     #dir %{_datadir}/mime/packages
113     #dir %{_datadir}/applications
114     %dir %{_datadir}/icons/hicolor
115     %dir %{_datadir}/icons/hicolor/32x32
116     %dir %{_datadir}/icons/hicolor/32x32/apps
117     %dir %{_datadir}/icons/hicolor/32x32/mimetypes
118     %dir %{_datadir}/icons/hicolor/scalable
119     %dir %{_datadir}/icons/hicolor/scalable/apps
120     %dir %{_datadir}/icons/hicolor/scalable/mimetypes
121     %dir %{_datadir}/%{name}
122     %dir %{_datadir}/%{name}/translations
123     %dir %{_datadir}/metainfo
124     #dir %{_datadir}/man
125     #dir %{_datadir}/man/man1
126     #dir %{_datadir}/man/fr
127     #dir %{_datadir}/man/fr/man1
128     %{_bindir}/%{name}
129     %{_datadir}/mime/packages/org.rncbc.%{name}.xml
130     %{_datadir}/applications/org.rncbc.%{name}.desktop
131     %{_datadir}/icons/hicolor/32x32/apps/org.rncbc.%{name}.png
132     %{_datadir}/icons/hicolor/scalable/apps/org.rncbc.%{name}.svg
133     %{_datadir}/icons/hicolor/32x32/mimetypes/org.rncbc.%{name}.application-x-%{name}*.png
134     %{_datadir}/icons/hicolor/scalable/mimetypes/org.rncbc.%{name}.application-x-%{name}*.svg
135     %{_datadir}/%{name}/translations/%{name}_*.qm
136     %{_datadir}/metainfo/org.rncbc.%{name}.metainfo.xml
137     %{_datadir}/man/man1/%{name}.1.gz
138     %{_datadir}/man/fr/man1/%{name}.1.gz
139    
140     %changelog
141 capela 4048 * Mon Oct 3 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
142     - An Early-Autumn'22 Release.
143 capela 4046 * Sat Apr 2 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
144     - A Spring'22 Release.
145     * Sun Jan 9 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
146     - A Winter'22 Release.
147     * Sun Jul 4 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
148     - Early-Summer'21 release.
149     * Tue May 11 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
150     - Spring'21 release.
151     * Sun Mar 14 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
152     - End-of-Winter'21 release.
153     * Sun Feb 7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
154     - Winter'21 release.
155     * Thu Dec 17 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
156     - Winter'20 release.
157     * Fri Jul 31 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.3
158     - Summer'20 release.
159     * Tue Mar 24 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.2
160     - Spring'20 release.
161     * Sun Dec 22 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.1
162     - Winter'19 release.
163     * Thu Oct 17 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.0
164     - Autumn'19 release.
165     * Fri Jul 12 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.6
166     - Summer'19 release.
167     * Thu Apr 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.5
168     - Spring-Break'19 release.
169     * Mon Mar 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.4
170     - Pre-LAC2019 release frenzy.
171     * Thu Dec 06 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.3
172     - An End of Autumn'18 Release.
173     * Sun Jul 22 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.2
174     - Summer'18 Release.
175     * Mon May 21 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.1
176     - Pre-LAC2018 release frenzy.
177     * Tue Dec 12 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.5.0
178     - An Autumn'17 release.
179     * Thu Apr 27 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.4.3
180     - Pre-LAC2017 release frenzy.
181     * Mon Nov 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.2
182     - A Fall'16 release.
183     * Wed Sep 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.1
184     - End of Summer'16 release.
185     * Tue Apr 5 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.0
186     - Spring'16 release frenzy.
187     * Sun Jul 19 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.1
188     - Summer'15 release frenzy.
189     * Wed Mar 25 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.0
190     - Pre-LAC2015 release frenzy.
191     * Tue Dec 31 2013 Rui Nuno Capela <rncbc@rncbc.org> 0.2.3
192     - A fifth of a Jubilee release.
193     * Mon May 17 2010 Rui Nuno Capela <rncbc@rncbc.org>
194     - Standard desktop icon fixing.
195     * Sat Aug 1 2009 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
196     - New 0.2.2 release.
197     * Thu Dec 6 2007 Rui Nuno Capela <rncbc@rncbc.org>
198     - Qt4 migration complete.
199     * Mon Jun 25 2007 Rui Nuno Capela <rncbc@rncbc.org>
200     - Application icon is now installed to (prefix)/share/pixmaps.
201     - Declared fundamental build and run-time requirements.
202     - Destination install directory prefix is now in spec.
203     - Spec is now a bit more openSUSE compliant.
204     * Mon Jan 15 2007 Rui Nuno Capela <rncbc@rncbc.org>
205     - Added sampler channel FX send support at session save code-level.
206     - Global sampler volume slider/spinbox combo is now featured.
207     * Sun Dec 17 2006 Rui Nuno Capela <rncbc@rncbc.org>
208     - Added preliminary MIDI instrument mapping support.
209     * Thu Jun 01 2006 Rui Nuno Capela <rncbc@rncbc.org>
210     - Take a chance for a new 0.1.3 release.
211     - Changed deprecated copyright attribute to license.
212     * Wed Aug 24 2005 Rui Nuno Capela <rncbc@rncbc.org>
213     - Prepared auto-generation from configure.
214     * Tue Aug 16 2005 Rui Nuno Capela <rncbc@rncbc.org>
215     - Get in sync with latest offerings from liblscp (0.3.1) and
216     specially libgig (2.0.2) which broke previous ABI, somewhat.
217     * Thu Jun 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
218     - Even minor workings needs a rest.
219     * Mon Jun 13 2005 Rui Nuno Capela <rncbc@rncbc.org>
220     - The mantra of bugfixes.
221     * Mon May 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
222     - Device configuration breakthrough.
223     * Fri Mar 4 2005 Rui Nuno Capela <rncbc@rncbc.org>
224     - Fifth alpha-release.
225     * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
226     - Prepared for the fourth alpha release.
227     * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
228     - Prepared for the fourth alpha release.
229     * Wed Jun 2 2004 Rui Nuno Capela <rncbc@rncbc.org>
230     - Created initial qsampler.spec

  ViewVC Help
Powered by ViewVC