/[svn]/qsampler/trunk/rpm/qsampler.spec
ViewVC logotype

Annotation of /qsampler/trunk/rpm/qsampler.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 4056 - (hide annotations) (download)
Thu Mar 23 10:03:02 2023 UTC (13 months ago) by capela
File size: 8643 byte(s)
* An Early-Spring'23 Release (v0.9.9)
1 capela 4046 #
2     # spec file for package qsampler
3     #
4 capela 4056 # Copyright (C) 2004-2023, rncbc aka Rui Nuno Capela. All rights reserved.
5 capela 4046 # Copyright (C) 2007,2008,2015 Christian Schoenebeck
6     #
7     # All modifications and additions to the file contributed by third parties
8     # remain the property of their copyright owners, unless otherwise agreed
9     # upon. The license for this file, and modifications and additions to the
10     # file, is the same license as for the pristine package itself (unless the
11     # license for the pristine package is not an Open Source License, in which
12     # case the license is the MIT License). An "Open Source License" is a
13     # license that conforms to the Open Source Definition (Version 1.9)
14     # published by the Open Source Initiative.
15     #
16     # Please submit bugfixes or comments via http://bugs.opensuse.org/
17     #
18    
19     %define name qsampler
20 capela 4056 %define version 0.9.9
21     %define release 53.1
22 capela 4046
23 capela 4050 %define _prefix /usr
24 capela 4046
25     %if %{defined fedora}
26     %define debug_package %{nil}
27     %endif
28    
29     %if 0%{?fedora_version} >= 34 || 0%{?suse_version} > 1500 || ( 0%{?sle_version} == 150200 && 0%{?is_opensuse} )
30     %define qt_major_version 6
31     %else
32     %define qt_major_version 5
33     %endif
34    
35     Summary: A LinuxSampler Qt GUI interface
36     Name: %{name}
37     Version: %{version}
38     Release: %{release}
39     License: GPL-2.0+
40     Group: Productivity/Multimedia/Sound/Midi
41     Source0: %{name}-%{version}.tar.gz
42     URL: http://qsampler.sourceforge.net/
43     Packager: rncbc.org
44    
45     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
46    
47     BuildRequires: coreutils
48     BuildRequires: pkgconfig
49     BuildRequires: glibc-devel
50 capela 4056 BuildRequires: cmake >= 3.15
51     %if 0%{?sle_version} >= 150200 && 0%{?is_opensuse}
52     BuildRequires: gcc10 >= 10
53     BuildRequires: gcc10-c++ >= 10
54     %define _GCC /usr/bin/gcc-10
55     %define _GXX /usr/bin/g++-10
56 capela 4046 %else
57 capela 4056 BuildRequires: gcc >= 10
58     BuildRequires: gcc-c++ >= 10
59     %define _GCC /usr/bin/gcc
60     %define _GXX /usr/bin/g++
61 capela 4046 %endif
62     %if 0%{qt_major_version} == 6
63     %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
64 capela 4050 BuildRequires: qtbase6-static >= 6.1
65 capela 4046 BuildRequires: qttools6-static
66     BuildRequires: qttranslations6-static
67     BuildRequires: qtsvg6-static
68 capela 4056 BuildRequires: qtwayland6-static
69 capela 4046 %else
70 capela 4050 BuildRequires: cmake(Qt6LinguistTools)
71     BuildRequires: pkgconfig(Qt6Core)
72     BuildRequires: pkgconfig(Qt6Gui)
73     BuildRequires: pkgconfig(Qt6Widgets)
74     BuildRequires: pkgconfig(Qt6Svg)
75     BuildRequires: pkgconfig(Qt6Network)
76 capela 4046 %endif
77     %else
78 capela 4050 BuildRequires: cmake(Qt5LinguistTools)
79     BuildRequires: pkgconfig(Qt5Core)
80     BuildRequires: pkgconfig(Qt5Gui)
81     BuildRequires: pkgconfig(Qt5Widgets)
82     BuildRequires: pkgconfig(Qt5Svg)
83     BuildRequires: pkgconfig(Qt5Network)
84 capela 4046 %endif
85     BuildRequires: liblscp-devel >= 0.5.6
86     BuildRequires: libgig-devel >= 3.3.0
87    
88     %description
89     Qsampler is a LinuxSampler GUI front-end application written in C++ around
90     the Qt framework using Qt Designer. For the moment it just wraps the client
91     interface of LinuxSampler Control Protocol (LSCP) (http://www.linuxsampler.org).
92    
93     %prep
94     %setup -q
95    
96     %build
97     %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
98     source /opt/qt6.4-static/bin/qt6.4-static-env.sh
99     %endif
100 capela 4056 CXX=%{_GXX} CC=%{_GCC} \
101 capela 4046 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
102     cmake --build build %{?_smp_mflags}
103    
104     %install
105     DESTDIR="%{buildroot}" \
106     cmake --install build
107    
108     %clean
109     [ -d "%{buildroot}" -a "%{buildroot}" != "/" ] && %__rm -rf "%{buildroot}"
110    
111     %files
112     %defattr(-,root,root)
113 capela 4056 %license LICENSE
114     %doc README TRANSLATORS ChangeLog
115 capela 4046 #dir %{_datadir}/mime
116     #dir %{_datadir}/mime/packages
117     #dir %{_datadir}/applications
118     %dir %{_datadir}/icons/hicolor
119     %dir %{_datadir}/icons/hicolor/32x32
120     %dir %{_datadir}/icons/hicolor/32x32/apps
121     %dir %{_datadir}/icons/hicolor/32x32/mimetypes
122     %dir %{_datadir}/icons/hicolor/scalable
123     %dir %{_datadir}/icons/hicolor/scalable/apps
124     %dir %{_datadir}/icons/hicolor/scalable/mimetypes
125     %dir %{_datadir}/%{name}
126     %dir %{_datadir}/%{name}/translations
127     %dir %{_datadir}/metainfo
128     #dir %{_datadir}/man
129     #dir %{_datadir}/man/man1
130     #dir %{_datadir}/man/fr
131     #dir %{_datadir}/man/fr/man1
132     %{_bindir}/%{name}
133     %{_datadir}/mime/packages/org.rncbc.%{name}.xml
134     %{_datadir}/applications/org.rncbc.%{name}.desktop
135     %{_datadir}/icons/hicolor/32x32/apps/org.rncbc.%{name}.png
136     %{_datadir}/icons/hicolor/scalable/apps/org.rncbc.%{name}.svg
137     %{_datadir}/icons/hicolor/32x32/mimetypes/org.rncbc.%{name}.application-x-%{name}*.png
138     %{_datadir}/icons/hicolor/scalable/mimetypes/org.rncbc.%{name}.application-x-%{name}*.svg
139     %{_datadir}/%{name}/translations/%{name}_*.qm
140     %{_datadir}/metainfo/org.rncbc.%{name}.metainfo.xml
141     %{_datadir}/man/man1/%{name}.1.gz
142     %{_datadir}/man/fr/man1/%{name}.1.gz
143    
144     %changelog
145 capela 4056 * Thu Mar 23 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.9
146     - An Early-Spring'23 Release.
147 capela 4054 * Wed Dec 28 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.8
148     - An End-of-Year'22 Release.
149 capela 4048 * Mon Oct 3 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
150     - An Early-Autumn'22 Release.
151 capela 4046 * Sat Apr 2 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
152     - A Spring'22 Release.
153     * Sun Jan 9 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
154     - A Winter'22 Release.
155     * Sun Jul 4 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
156     - Early-Summer'21 release.
157     * Tue May 11 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
158     - Spring'21 release.
159     * Sun Mar 14 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
160     - End-of-Winter'21 release.
161     * Sun Feb 7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
162     - Winter'21 release.
163     * Thu Dec 17 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
164     - Winter'20 release.
165     * Fri Jul 31 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.3
166     - Summer'20 release.
167     * Tue Mar 24 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.2
168     - Spring'20 release.
169     * Sun Dec 22 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.1
170     - Winter'19 release.
171     * Thu Oct 17 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.0
172     - Autumn'19 release.
173     * Fri Jul 12 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.6
174     - Summer'19 release.
175     * Thu Apr 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.5
176     - Spring-Break'19 release.
177     * Mon Mar 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.4
178     - Pre-LAC2019 release frenzy.
179     * Thu Dec 06 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.3
180     - An End of Autumn'18 Release.
181     * Sun Jul 22 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.2
182     - Summer'18 Release.
183     * Mon May 21 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.1
184     - Pre-LAC2018 release frenzy.
185     * Tue Dec 12 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.5.0
186     - An Autumn'17 release.
187     * Thu Apr 27 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.4.3
188     - Pre-LAC2017 release frenzy.
189     * Mon Nov 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.2
190     - A Fall'16 release.
191     * Wed Sep 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.1
192     - End of Summer'16 release.
193     * Tue Apr 5 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.0
194     - Spring'16 release frenzy.
195     * Sun Jul 19 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.1
196     - Summer'15 release frenzy.
197     * Wed Mar 25 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.0
198     - Pre-LAC2015 release frenzy.
199     * Tue Dec 31 2013 Rui Nuno Capela <rncbc@rncbc.org> 0.2.3
200     - A fifth of a Jubilee release.
201     * Mon May 17 2010 Rui Nuno Capela <rncbc@rncbc.org>
202     - Standard desktop icon fixing.
203     * Sat Aug 1 2009 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
204     - New 0.2.2 release.
205     * Thu Dec 6 2007 Rui Nuno Capela <rncbc@rncbc.org>
206     - Qt4 migration complete.
207     * Mon Jun 25 2007 Rui Nuno Capela <rncbc@rncbc.org>
208     - Application icon is now installed to (prefix)/share/pixmaps.
209     - Declared fundamental build and run-time requirements.
210     - Destination install directory prefix is now in spec.
211     - Spec is now a bit more openSUSE compliant.
212     * Mon Jan 15 2007 Rui Nuno Capela <rncbc@rncbc.org>
213     - Added sampler channel FX send support at session save code-level.
214     - Global sampler volume slider/spinbox combo is now featured.
215     * Sun Dec 17 2006 Rui Nuno Capela <rncbc@rncbc.org>
216     - Added preliminary MIDI instrument mapping support.
217     * Thu Jun 01 2006 Rui Nuno Capela <rncbc@rncbc.org>
218     - Take a chance for a new 0.1.3 release.
219     - Changed deprecated copyright attribute to license.
220     * Wed Aug 24 2005 Rui Nuno Capela <rncbc@rncbc.org>
221     - Prepared auto-generation from configure.
222     * Tue Aug 16 2005 Rui Nuno Capela <rncbc@rncbc.org>
223     - Get in sync with latest offerings from liblscp (0.3.1) and
224     specially libgig (2.0.2) which broke previous ABI, somewhat.
225     * Thu Jun 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
226     - Even minor workings needs a rest.
227     * Mon Jun 13 2005 Rui Nuno Capela <rncbc@rncbc.org>
228     - The mantra of bugfixes.
229     * Mon May 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
230     - Device configuration breakthrough.
231     * Fri Mar 4 2005 Rui Nuno Capela <rncbc@rncbc.org>
232     - Fifth alpha-release.
233     * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
234     - Prepared for the fourth alpha release.
235     * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
236     - Prepared for the fourth alpha release.
237     * Wed Jun 2 2004 Rui Nuno Capela <rncbc@rncbc.org>
238     - Created initial qsampler.spec

  ViewVC Help
Powered by ViewVC