/[svn]/qsampler/trunk/rpm/qsampler.spec
ViewVC logotype

Contents of /qsampler/trunk/rpm/qsampler.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 4109 - (show annotations) (download)
Sun Apr 7 15:42:43 2024 UTC (8 days, 13 hours ago) by capela
File size: 9032 byte(s)
- Prepping the unthinkable (aka. v1.0.0-rc1)
1 #
2 # spec file for package qsampler
3 #
4 # Copyright (C) 2004-2024, rncbc aka Rui Nuno Capela. All rights reserved.
5 # Copyright (C) 2007,2008,2015 Christian Schoenebeck
6 #
7 # All modifications and additions to the file contributed by third parties
8 # remain the property of their copyright owners, unless otherwise agreed
9 # upon. The license for this file, and modifications and additions to the
10 # file, is the same license as for the pristine package itself (unless the
11 # license for the pristine package is not an Open Source License, in which
12 # case the license is the MIT License). An "Open Source License" is a
13 # license that conforms to the Open Source Definition (Version 1.9)
14 # published by the Open Source Initiative.
15 #
16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
17 #
18
19 %define name qsampler
20 %define version 0.9.90
21 %define release 1.1
22
23 %define _prefix /usr
24
25 %if %{defined fedora}
26 %define debug_package %{nil}
27 %endif
28
29 %if 0%{?fedora_version} >= 34 || 0%{?suse_version} > 1500 || ( 0%{?sle_version} == 150200 && 0%{?is_opensuse} )
30 %define qt_major_version 6
31 %else
32 %define qt_major_version 5
33 %endif
34
35 Summary: A LinuxSampler Qt GUI interface
36 Name: %{name}
37 Version: %{version}
38 Release: %{release}
39 License: GPL-2.0+
40 Group: Productivity/Multimedia/Sound/Midi
41 Source0: %{name}-%{version}.tar.gz
42 URL: http://qsampler.sourceforge.net/
43 Packager: rncbc.org
44
45 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
46
47 BuildRequires: coreutils
48 BuildRequires: pkgconfig
49 BuildRequires: glibc-devel
50 BuildRequires: cmake >= 3.15
51 %if 0%{?sle_version} >= 150200 && 0%{?is_opensuse}
52 BuildRequires: gcc10 >= 10
53 BuildRequires: gcc10-c++ >= 10
54 %define _GCC /usr/bin/gcc-10
55 %define _GXX /usr/bin/g++-10
56 %else
57 BuildRequires: gcc >= 10
58 BuildRequires: gcc-c++ >= 10
59 %define _GCC /usr/bin/gcc
60 %define _GXX /usr/bin/g++
61 %endif
62 %if 0%{qt_major_version} == 6
63 %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
64 BuildRequires: qtbase6.6-static >= 6.6
65 BuildRequires: qttools6.6-static
66 BuildRequires: qttranslations6.6-static
67 BuildRequires: qtsvg6.6-static
68 %else
69 BuildRequires: cmake(Qt6LinguistTools)
70 BuildRequires: pkgconfig(Qt6Core)
71 BuildRequires: pkgconfig(Qt6Gui)
72 BuildRequires: pkgconfig(Qt6Widgets)
73 BuildRequires: pkgconfig(Qt6Svg)
74 BuildRequires: pkgconfig(Qt6Network)
75 %endif
76 %else
77 BuildRequires: cmake(Qt5LinguistTools)
78 BuildRequires: pkgconfig(Qt5Core)
79 BuildRequires: pkgconfig(Qt5Gui)
80 BuildRequires: pkgconfig(Qt5Widgets)
81 BuildRequires: pkgconfig(Qt5Svg)
82 BuildRequires: pkgconfig(Qt5Network)
83 %endif
84 BuildRequires: liblscp-devel >= 0.5.6
85 BuildRequires: libgig-devel >= 3.3.0
86
87 %description
88 Qsampler is a LinuxSampler GUI front-end application written in C++ around
89 the Qt framework using Qt Designer. For the moment it just wraps the client
90 interface of LinuxSampler Control Protocol (LSCP) (http://www.linuxsampler.org).
91
92 %prep
93 %setup -q
94
95 %build
96 %if 0%{?sle_version} == 150200 && 0%{?is_opensuse}
97 source /opt/qt6.6-static/bin/qt6.6-static-env.sh
98 %endif
99 CXX=%{_GXX} CC=%{_GCC} \
100 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build
101 cmake --build build %{?_smp_mflags}
102
103 %install
104 DESTDIR="%{buildroot}" \
105 cmake --install build
106
107 %clean
108 [ -d "%{buildroot}" -a "%{buildroot}" != "/" ] && %__rm -rf "%{buildroot}"
109
110 %files
111 %defattr(-,root,root)
112 %license LICENSE
113 %doc README TRANSLATORS ChangeLog
114 #dir %{_datadir}/mime
115 #dir %{_datadir}/mime/packages
116 #dir %{_datadir}/applications
117 %dir %{_datadir}/icons/hicolor
118 %dir %{_datadir}/icons/hicolor/32x32
119 %dir %{_datadir}/icons/hicolor/32x32/apps
120 %dir %{_datadir}/icons/hicolor/32x32/mimetypes
121 %dir %{_datadir}/icons/hicolor/scalable
122 %dir %{_datadir}/icons/hicolor/scalable/apps
123 %dir %{_datadir}/icons/hicolor/scalable/mimetypes
124 %dir %{_datadir}/%{name}
125 %dir %{_datadir}/%{name}/translations
126 %dir %{_datadir}/%{name}/palette
127 %dir %{_datadir}/metainfo
128 #dir %{_datadir}/man
129 #dir %{_datadir}/man/man1
130 #dir %{_datadir}/man/fr
131 #dir %{_datadir}/man/fr/man1
132 %{_bindir}/%{name}
133 %{_datadir}/mime/packages/org.rncbc.%{name}.xml
134 %{_datadir}/applications/org.rncbc.%{name}.desktop
135 %{_datadir}/icons/hicolor/32x32/apps/org.rncbc.%{name}.png
136 %{_datadir}/icons/hicolor/scalable/apps/org.rncbc.%{name}.svg
137 %{_datadir}/icons/hicolor/32x32/mimetypes/org.rncbc.%{name}.application-x-%{name}*.png
138 %{_datadir}/icons/hicolor/scalable/mimetypes/org.rncbc.%{name}.application-x-%{name}*.svg
139 %{_datadir}/%{name}/translations/%{name}_*.qm
140 %{_datadir}/metainfo/org.rncbc.%{name}.metainfo.xml
141 %{_datadir}/man/man1/%{name}.1.gz
142 %{_datadir}/man/fr/man1/%{name}.1.gz
143 %{_datadir}/%{name}/palette/*.conf
144
145 %changelog
146 * Wed Apr 10 2024 Rui Nuno Capela <rncbc@rncbc.org> 0.9.90
147 - A Spring'24 Release Candidate.
148 * Wed Jan 24 2024 Rui Nuno Capela <rncbc@rncbc.org> 0.9.12
149 - A Winter'24 Release.
150 * Sat Sep 9 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.11
151 - An End-of-Summer'23 Release.
152 * Thu Jun 1 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.10
153 - A Spring'23 Release.
154 * Thu Mar 23 2023 Rui Nuno Capela <rncbc@rncbc.org> 0.9.9
155 - An Early-Spring'23 Release.
156 * Wed Dec 28 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.8
157 - An End-of-Year'22 Release.
158 * Mon Oct 3 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
159 - An Early-Autumn'22 Release.
160 * Sat Apr 2 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
161 - A Spring'22 Release.
162 * Sun Jan 9 2022 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
163 - A Winter'22 Release.
164 * Sun Jul 4 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
165 - Early-Summer'21 release.
166 * Tue May 11 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
167 - Spring'21 release.
168 * Sun Mar 14 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
169 - End-of-Winter'21 release.
170 * Sun Feb 7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
171 - Winter'21 release.
172 * Thu Dec 17 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
173 - Winter'20 release.
174 * Fri Jul 31 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.3
175 - Summer'20 release.
176 * Tue Mar 24 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.6.2
177 - Spring'20 release.
178 * Sun Dec 22 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.1
179 - Winter'19 release.
180 * Thu Oct 17 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.6.0
181 - Autumn'19 release.
182 * Fri Jul 12 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.6
183 - Summer'19 release.
184 * Thu Apr 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.5
185 - Spring-Break'19 release.
186 * Mon Mar 11 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.5.4
187 - Pre-LAC2019 release frenzy.
188 * Thu Dec 06 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.3
189 - An End of Autumn'18 Release.
190 * Sun Jul 22 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.2
191 - Summer'18 Release.
192 * Mon May 21 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.5.1
193 - Pre-LAC2018 release frenzy.
194 * Tue Dec 12 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.5.0
195 - An Autumn'17 release.
196 * Thu Apr 27 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.4.3
197 - Pre-LAC2017 release frenzy.
198 * Mon Nov 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.2
199 - A Fall'16 release.
200 * Wed Sep 14 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.1
201 - End of Summer'16 release.
202 * Tue Apr 5 2016 Rui Nuno Capela <rncbc@rncbc.org> 0.4.0
203 - Spring'16 release frenzy.
204 * Sun Jul 19 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.1
205 - Summer'15 release frenzy.
206 * Wed Mar 25 2015 Rui Nuno Capela <rncbc@rncbc.org> 0.3.0
207 - Pre-LAC2015 release frenzy.
208 * Tue Dec 31 2013 Rui Nuno Capela <rncbc@rncbc.org> 0.2.3
209 - A fifth of a Jubilee release.
210 * Mon May 17 2010 Rui Nuno Capela <rncbc@rncbc.org>
211 - Standard desktop icon fixing.
212 * Sat Aug 1 2009 Rui Nuno Capela <rncbc@rncbc.org> 0.2.2
213 - New 0.2.2 release.
214 * Thu Dec 6 2007 Rui Nuno Capela <rncbc@rncbc.org>
215 - Qt4 migration complete.
216 * Mon Jun 25 2007 Rui Nuno Capela <rncbc@rncbc.org>
217 - Application icon is now installed to (prefix)/share/pixmaps.
218 - Declared fundamental build and run-time requirements.
219 - Destination install directory prefix is now in spec.
220 - Spec is now a bit more openSUSE compliant.
221 * Mon Jan 15 2007 Rui Nuno Capela <rncbc@rncbc.org>
222 - Added sampler channel FX send support at session save code-level.
223 - Global sampler volume slider/spinbox combo is now featured.
224 * Sun Dec 17 2006 Rui Nuno Capela <rncbc@rncbc.org>
225 - Added preliminary MIDI instrument mapping support.
226 * Thu Jun 01 2006 Rui Nuno Capela <rncbc@rncbc.org>
227 - Take a chance for a new 0.1.3 release.
228 - Changed deprecated copyright attribute to license.
229 * Wed Aug 24 2005 Rui Nuno Capela <rncbc@rncbc.org>
230 - Prepared auto-generation from configure.
231 * Tue Aug 16 2005 Rui Nuno Capela <rncbc@rncbc.org>
232 - Get in sync with latest offerings from liblscp (0.3.1) and
233 specially libgig (2.0.2) which broke previous ABI, somewhat.
234 * Thu Jun 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
235 - Even minor workings needs a rest.
236 * Mon Jun 13 2005 Rui Nuno Capela <rncbc@rncbc.org>
237 - The mantra of bugfixes.
238 * Mon May 23 2005 Rui Nuno Capela <rncbc@rncbc.org>
239 - Device configuration breakthrough.
240 * Fri Mar 4 2005 Rui Nuno Capela <rncbc@rncbc.org>
241 - Fifth alpha-release.
242 * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
243 - Prepared for the fourth alpha release.
244 * Tue Nov 16 2004 Rui Nuno Capela <rncbc@rncbc.org>
245 - Prepared for the fourth alpha release.
246 * Wed Jun 2 2004 Rui Nuno Capela <rncbc@rncbc.org>
247 - Created initial qsampler.spec

  ViewVC Help
Powered by ViewVC